Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I just found a tip to set the compose key manually:

setxkbmap -option compose:caps

Unfortunately, after running this several keypresses act as if the compose key had been pressed. For example, to get a tilde, I now have to press Shift-~ twice, and I can no longer figure out how to get a single or double quote - When I press that key twice (without pressing Caps Lock) I get a single ´ (without Shift) or ¨ (with Shift) character.

$ setxkbmap -print 
xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)" };
    xkb_types     { include "complete"  };
    xkb_compat    { include "complete"  };
    xkb_symbols   { include "pc+us(dvorak-intl)+inet(evdev)+level3(ralt_switch)+compose(caps)"  };
    xkb_geometry  { include "pc(pc105)" };
};

Setting the compose key to the more popular Right-Alt did not help - The results are the same with the following settings:

$ setxkbmap -print 
xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)" };
    xkb_types     { include "complete"  };
    xkb_compat    { include "complete"  };
    xkb_symbols   { include "pc+us(dvorak-intl)+inet(evdev)+level3(ralt_switch)+compose(ralt)"  };
    xkb_geometry  { include "pc(pc105)" };
};

Stranger still, even after disabling the compose key with setxkbmap -option the keys are still messed up.

On a different machine with GNOME 3 and similar settings it works just fine (Caps Lock, a, a produces å, while a single press of Shift-~ produces ~):

$ setxkbmap -print 
xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)" };
    xkb_types     { include "complete"  };
    xkb_compat    { include "complete"  };
    xkb_symbols   { include "pc+us(dvorak-alt-intl)+ch:2+inet(evdev)+compose(caps)" };
    xkb_geometry  { include "pc(pc105)" };
};

Maybe it's an LXDE issue - I'll test it next week.

share|improve this question
    
I don't get that with compose set to ralt, but I didn't set it the same way. –  Rob Apr 12 '12 at 15:34
    
@Rob: Changing it to ralt did not work. –  l0b0 Apr 12 '12 at 15:37
    
That behavior sounds like us-intl. Try pressing space after the troublesome keys. –  Kevin Apr 12 '12 at 23:11

1 Answer 1

up vote 2 down vote accepted

Turns out the problem was actually the keyboard layout - Switching to English (Dvorak alternative international no dead keys) (XKBVARIANT="dvorak-alt-intl" in /etc/default/keyboard) fixed it.

Unfortunately I can't find a way to set this for my user only.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.