Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to do a full system upgrade using pacman on ArchLinux. I have kernel 3.2.

When typing sudo pacman -Syu I got the following errors

:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade...
error: could not parse package description file 'libice-1.0.8-1/desc' from db 'extra'
resolving dependencies...
warning: cannot resolve "p11-kit>=0.12", a dependency of "gnutls"
warning: cannot resolve "vim-runtime=7.3.495-1", a dependency of "gvim"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      gnutls  gvim

Do you want to skip the above packages for this upgrade? [y/N] y
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia: requires linux<3.3

I've tried to reinstall libice but I got the following error

error: could not parse package description file 'libice-1.0.8-1/desc' from db 'extra'
warning: libice-1.0.8-1 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (package filename is not valid)

How can I fix this problem?

share|improve this question
    
Try running pacman -Syy before update. –  diffycat Apr 11 '12 at 10:01
1  
@diffycat Already did it –  Ben D Apr 11 '12 at 10:43
add comment

1 Answer

I believe you are using a mirror that's (way) out of sync.

The p11-kit, vim-runtime packages have been updated on 2012-04-01 and 2012-04-10 respectively. The nvidia package has been updated today (2012-04-11), so all you need to do is wait a while.

It's quite interesing that you have a linux package version 3.3, though and a gvim package from 2012-04-10. Did you change repositories (disabled testing) or mirrors lately? You might want to use the mirrorlist or mirrorlist updater to find an up-to-date mirror near you. This would most likely also repair your extra db file.

share|improve this answer
    
I don't know what I've done, but it seems to work now. Maybe a problem with my internet connection that was too slow. –  Ben D Apr 12 '12 at 7:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.