Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have to install wicd from its source rpm package but Apper-sentinel keeps waiting at license agreement requirement showing message waiting for service to start.

This (see the last comment in this post) thread has the solution from KDE session, but i can't find anything similar to configure-destop > file associations in GNOME-3 anywhere to move up "Install/Remove Software"..

share|improve this question
add comment

1 Answer

There are a couple of ways to fix your problem

1. Adjust the application used to open the RPM

  • Download an RPM, any RPM
  • Right click on it and go to properties
  • Go to the Open With tab
  • Adjust as needed

My defaults are at the end of the answer

2. Use the zypper command-line tool to install the downloaded RPM

In a console, run zypper in file.rpm

enter image description here

share|improve this answer
    
Thanks @Robert. 'Open With' tab has 4 installer options, 1st triggers /usr/bin/gpk-install-local-file and other 3 open Apper.. And i end up back to the same problem i originally had.. –  haywire Apr 11 '12 at 13:53
    
I have a completely different set of applications ( will update the answer ). If you can't install it using the GUI, I suggest that you drop to the command line and use sudo zypper in file.rpm . –  Robert Munteanu Apr 11 '12 at 13:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.