Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Running an Ubuntu desktop server. I installed virtual box, then installed CentOS as a virtual machine. Centos is not starting the eth0 network adaptor. When I start it manually, I cannot connect outside the machine.

Anyone know what I've done wrong? I'm new to Virtual Box and somewhat new to CentOS.

Virtual Box 4.1.12 and CentOS 6.2 and Ubuntu 11.10 64 bit. Using NAT addressing.

Networking for the Main Server:

eth0      Link encap:Ethernet  HWaddr c8:60:00:12:a7:9a  
          inet addr:10.0.0.99  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::ca60:ff:fe12:a79a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15492 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7192 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3083151 (3.0 MB)  TX bytes:1104784 (1.1 MB)
          Interrupt:41 Base address:0x4000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6398 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6398 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:789448 (789.4 KB)  TX bytes:789448 (789.4 KB)

Networking for the CentOS virtual Server:

eth0      Link encap:Ethernet  HWaddr 08:00:27:75:b2:9ac2
          inet addr:10.0.0.98  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fe75:b2c2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:1350 (1.3 KiB)


lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6398 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6398 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:789448 (789.4 KB)  TX bytes:789448 (789.4 KB)
share|improve this question
1  
Post ifconfig -a from guest and tell us what type of networking you have enabled in VM settings... –  pbm Apr 10 '12 at 19:22
add comment

1 Answer 1

up vote 3 down vote accepted

The issue with this appears to have been the NAT setting. It requires you to use 10.0.2.* addresses.

Also, when I thought about, NAT doesn't provide me with external access to that IP address. I changed it to bridged and everything now appears to be working.

Thanks for the help.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.