Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running linux mint LMDE 64 bit version, I have to install this i386 software to use my modem. So I did it with --force-architecture mode, installation completed with errors. Here is the log

dpkg: warning: overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
Selecting previously unselected package crossplatformui.
(Reading database ... 175681 files and directories currently installed.)
Unpacking crossplatformui (from CrossPlatformUI-V1.0.27-BSNL-i386-ubuntu.deb) ...
Setting up crossplatformui (1.0.27) ...
Stopping ACPI services....
Starting ACPI services....
package libqtgui4 exist
QT_VERSION = 4
make -C /lib/modules/3.2.0-2-amd64/build M=/usr/local/bin/ztemtApp/zteusbserial/below2.6.27 modules
make[1]: Entering directory `/usr/src/linux-headers-3.2.0-2-amd64'
  CC [M]  /usr/local/bin/ztemtApp/zteusbserial/below2.6.27/usb-serial.o
/usr/local/bin/ztemtApp/zteusbserial/below2.6.27/usb-serial.c:34:28: fatal error: linux/smp_lock.h: No such file or directory
compilation terminated.
make[4]: *** [/usr/local/bin/ztemtApp/zteusbserial/below2.6.27/usb-serial.o] Error 1
make[3]: *** [_module_/usr/local/bin/ztemtApp/zteusbserial/below2.6.27] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.2.0-2-amd64'
make: *** [modules] Error 2
dpkg: error processing crossplatformui (--install):
 subprocess installed post-installation script returned error exit status 2
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 crossplatformui

Now if I start the app it says

phanindra@phanindra:~$ ztemtapp 
/usr/bin/ztemtapp: 4: exec: /usr/local/bin/ztemtApp/bin/App: not found

How to fix this?

Update:

I have installed ia32-libs now

and now it says

phanindra@phanindra:~$ ztemtapp 
/usr/local/bin/ztemtApp/bin/App: error while loading shared libraries: libQtGui.so.4: wrong ELF class: ELFCLASS64

whn I started the app

share|improve this question
    
All I can say from this log is that there was a problem on or near line 34 of /usr/local/bin/ztemtApp/zteusbserial/below2.6.27/usb-serial.c. You'll need to post a link to that file (and possible other ones it #includes) for anyone to help. –  Scott Lamb Apr 10 '12 at 15:57
    
Do you have the kernel headers installed? –  Renan Apr 10 '12 at 17:38
    
Don't use force. apt was trying to prevent you from making a mistake, and you thought you knew better than it, but you didn't. –  Paul Tomblin Apr 10 '12 at 18:41
    
I really dont know what are kernel headers etc etc, can any one care to explain? –  pahnin Apr 10 '12 at 22:34
    
@ScottLamb do u want me to share the deb file? –  pahnin Apr 10 '12 at 22:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.