Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

(using Ubuntu 10.04 LTS on a netbook prior to any updates) The wireless works fine, the wired connection has been tested using a Windows computer.

Choosing auto eth0 from the power manager fails.

Using Wicd network manager - pressing connect to Wired Nework - 'connecting' Wired network: Obtaining IP address... - Connection Failed: Unable to Get IP Address

alex@alex-laptop:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:24:54:df:22:d5  
      inet6 addr: fe80::224:54ff:fedf:22d5/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:8558 errors:0 dropped:0 overruns:0 frame:0
      TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:526280 (526.2 KB)  TX bytes:9564 (9.5 KB)
      Interrupt:18 

testing dhclient on eth0

alex@alex-laptop:~$ sudo dhclient eth0
[sudo] password for alex: 
Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/00:24:54:df:22:d5
Sending on   LPF/eth0/00:24:54:df:22:d5
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

running dmesg

    alex@alex-laptop:~$ dmesg | grep eth0
[    1.092888] sky2 eth0: addr 00:24:54:df:22:d5
[   13.521498] sky2 eth0: enabling interface
[   13.522027] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   15.036628] sky2 eth0: Link is up at 100 Mbps, full duplex, flow control rx
[   15.099270] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   21.505203] sky2 eth0: disabling interface
[   21.516896] sky2 eth0: enabling interface
[   21.517394] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   21.544054] sky2 eth0: disabling interface
[   21.573775] sky2 eth0: enabling interface
[   21.574326] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   23.085959] sky2 eth0: Link is up at 100 Mbps, full duplex, flow control rx
[   23.086287] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   33.488031] eth0: no IPv6 routers present
[   98.269052] sky2 eth0: disabling interface
[   98.289665] sky2 eth0: enabling interface
[   98.290176] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   99.795289] sky2 eth0: Link is up at 100 Mbps, full duplex, flow control rx
[   99.795826] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  110.272732] eth0: no IPv6 routers present
[  133.463522] sky2 eth0: Link is down.
[ 7748.854103] sky2 eth0: Link is up at 100 Mbps, full duplex, flow control rx

running ifup

    alex@alex-laptop:~$ sudo ifup eth0
[sudo] password for alex: 
Ignoring unknown interface eth0=eth0.

running lspci

    alex@alex-laptop:~$ lspci | grep -i ethernet
09:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller
alex@alex-laptop:~$ lshw -c Network | driver
WARNING: you should run this program as super-user.
No command 'driver' found, did you mean:
 Command 'drivel' from package 'drivel' (universe)
driver: command not found
alex@alex-laptop:~$ lshw -c Network | grep driver
WARNING: you should run this program as super-user.
       configuration: broadcast=yes driver=wl0 driverversion=5.60.48.36 latency=0 multicast=yes wireless=IEEE 802.11
       configuration: broadcast=yes driver=sky2 driverversion=1.25 firmware=N/A latency=0 multicast=yes

running route

  alex@alex-laptop:/etc$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
link-local      *               255.255.0.0     U     0      0        0 pan0
link-local      *               255.255.0.0     U     0      0        0 eth1

I have seen advice to edit the /etc/dhcp3/dhclient.conf file by putting a # infront of rfc3442 and save and restart, but this did not work.

Then I tried adding to /etc/network/interfaces auto eth0 iface eth0 inet dhcp. Originally the interfaces file was:

auto lo
iface lo inet loopback

which I edited to be:

 auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

and then removing network manager from start up, and after a reboot this also did not help. any ideas why the wired connection still does not work?

share|improve this question
1  
Are you sure that there is a dhcp server for the wired LAN connection? I don't think there is any dhcp server for your wired LAN. You might have to give static ip address by putting entry in /etc/network/interfaces file. Are you behind any kind of NAT machine ? –  pradeepchhetri Apr 7 '12 at 9:15
    
@pradeepchhetri, I am not sure if there is a dhcp server for the wired LAN. Now that I think of it, probably not, I agree. I am in a house with a router and LAN cable, so I assume that this connects directly to the ISP without a NAT machine. What kind of static ip address should I give? Why wouldn't it be set automatically? What would the static ip correspond to? –  Vass Apr 7 '12 at 9:39
    
@Vass To answer your questions in order: How would anyone know without details? Depending on the kind of POP presence there is in the house there may be various methods of assigning an IP address. 3. This questions makes no sense whatsoever. And to ask a question: Have you tried "sniffing" the wire to see what kind of traffic you get? –  Karlson Apr 9 '12 at 14:32
    
@Karlson, I have not actually done this before, so I am unsure how to progress? Could you post an answer of such a set of actions to perform or investigation. Would I need to sniff the wire with wireshark and search for what type of information? –  Vass Apr 9 '12 at 20:57

1 Answer 1

Your first block indicates there's no DHCP server on your local network. When you said the network interface was tested under Windows was it on this network? If it was, simply copy the settings. If it wasn't, call your ISP for the connection information. There may be some PPPoE magic required or even providing your MAC address so they can enable it to get a DHCP configuration.

share|improve this answer
    
thanks for this answer. What settings from the windows computer should I look to copy? The windows laptop was connected to the LAN cable and then the ubuntu laptop. –  Vass Apr 10 '12 at 8:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.