Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a dual boot system with windows xp and a fresh install of linux mint 12 lxde. I installed the video card drivers for my ati radeon (hd5570). After this I get an out of range error on my monitor every time I reboot. The grub menu is still visible though.

I don't know if it is related but before installing the drivers I also used xrandr to add the native resolution of my monitor 1280x1024 and saved that in my xprofile. I used the guide from here https://wiki.ubuntu.com/X/Config/Resolution#Adding_undetected_resolutions. I added something similar:

xrandr --newmode "1280x1024_60.00"   38.25  800 832 912 1024  600 603 607 624 -hsync +vsync
xrandr --addmode VGA-0 1280x1024
xrandr --output VGA-0 --mode 1280x1024

BTW: I commented out these lines before installing the video card drivers. I'm just not exactly sure what is the cause of the error. Setting the resolution to 1280x1024 or installing the drivers.

How can I solve this problem? How can I uninstall the video card driver from command line? I don't really care about having these drivers or not, there was a popup saying that there are proprietary drivers available and I installed it. I probably won't use this for gaming. Any help is appreciated.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

OK whatever, thanks for the help.

  • Select recovery mode in grub
  • select remount
  • enter root menu
  • type the 2 commands separately

    sudo sh /usr/share/ati/fglrx-uninstall.sh

    sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

If you type aptitupe here you also get a text mode version of the synaptic manager and I think that can be used also

I later found out that you can go into text mode by pressin ctrl+alt+f1 and to go back press ctrl+alt+f7

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.