Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I did install ffmpeg with winff, unsuccessfully when I try converting avi to x264, it says I don't have it. When I try to convert mp4 to Xvid I get unknown encoder 'libxvid'. It's like nothing really works except avi Msi compatible using winff, anybody help?

share|improve this question
add comment

1 Answer 1

First, remove the actual ffmpeg installation yum remove ffmpeg ffmpeg-devel, you will have to install the DAG RPM repositories which contains huge amount of rpm packages. It’s very easy. Just install the latest rpmforge-release package for your distribution and architecture.

This will automatically install the configuration and GPG keys that are for safely installing RPMforge packages.

nano -w /etc/yum.repos.d/dag.repo

Insert :-

[dag]
name=Dag RPM Repository for Red Hat Enterprise Linux
baseurl=http://apt.sw.be/redhat/el$releasever/en/$basearch/dag
gpgcheck=1
enabled=1

Then save the repo file also you can update RPM through rpmforge :-

rpm -Uhv http://apt.sw.be/redhat/el5/en/x86_64/rpmforge/RPMS//rpmforge-release-0.3.6-1.el5.rf.x86_64.rpm

yum update

Installing FFMPEG.:-

yum install ffmpeg ffmpeg-devel

If Seems there is some lib problems along the way so in /etc/ld.so.conf add

/usr/local/lib

also check /etc/ld.so.conf.d and make sure there are no .conf files that may be loading other files.

then

ldconfig -v

I hope it helps...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.