Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm having a problem with urllib, urllib2 and requests, three python libraries.

I use Ubuntu 10.04.4 LTS and python 2.6.5 (we can use with python) (but I had installed manually, after the problem, python 2.5.6 and python 2.7, respectively python2.5, python2.7).

Initially my packages worked fine, but in some point, maybe updating the kernel, not sure, nothing works.

The strange that is if I run python using root, the commands works fine (please see this question in Stackoverflow), but using the common user don't works.

I think the problem is, I had installed this packages using pip and easy_install with root, not using the common user. Initially I couldnt install with my user, so I tried root and worked, but with the problem above showed in the stackoverflow question.

So I would like how to remove, probably manually (looks like or Ubuntu 10.04.04 don't have a way to easy uninstall the packages, using pip and easy_install, or I don't know one), this libraries of my system.

share|improve this question
    
“nothing works”, “don't works”: ok, so what happens if you try to use them? You get error messages? Your computer blows up? Copy-paste the exact commands you ran and all the messages you get. –  Gilles Apr 4 '12 at 23:36

1 Answer 1

up vote 0 down vote accepted

There is no issues with the python package module installation using root login or some other user other than root.

Anyway you can uninstall the python package using pip and easy_install as below.

#pip uninstall packagename

#easy_install -m PackageName
share|improve this answer
    
Well, this should work, but unfortunally, neither pip and easy_install recognize these commands, probably because the stable packages to Ubuntu 10.04.4 Long Time Support don't have these commands. –  GarouDan Apr 5 '12 at 1:10
    
I had changed to 12.04 and this isn't a problem to me anymore, so I will embrace this answer. –  GarouDan May 13 '12 at 23:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.