Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How do I set manually environment variables for Metasploit, when I execute db_driver I get this message:

[*] No Active Driver
[*]        Available: 

[*]     DB Support: Enable the postgresql driver with the following command:
[*]                   * This requires libpq-dev and a build environment
[*]                 $ gem install postgres
[*]                 $ gem install pg # is an alternative that may work

After googling, I find that Metasploit set some environment variables, and with that can load the installed drivers, but to me it's looks like Metasploit does not set environment variables.

share|improve this question
    
Did the commands the error message told you to run not work or why do you want to set environment variables? – Wieland Apr 3 '12 at 9:32
    
Setting environment variables help metasploit to load inatalled databases drivers correctly, see this mail. – SIFE Apr 3 '12 at 12:04
    
Where did you run msfconsole? Is it /pentest/exploits/framework3/msfconsole? – cuonglm Mar 17 '14 at 7:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.