Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

The touchpad comes back to life after a few seconds. The Windows driver had a disable-entirely option. I do not want to use the touchpad at all, so anything up to and including a hardware fix is now open for consideration.

The laptop is an HP Pavilion DM1 and the Linux is a fresh install of Mint Lisa (12) with GNOME.

And yes, I tried everything here with no effect.

share|improve this question
    
Gave up and switched back to Ubuntu now. In 10.04, blacklisting psmouse works. –  DavidF Apr 11 '12 at 9:50

2 Answers 2

up vote 2 down vote accepted

Well, for future reference at least:

synclient touchpadoff=1

Disables the touchpad, touchpadoff=0 enables it again.

I put that in a script file, added it to the Autostart stuff, and when my desktop starts up, a few seconds later as the autostart files are executed, the touchpad mouse is OFF.

This is handy since I can run another script 'enable-touchpad', which turns it back on (I have a 'toggle-touchpad' too!), which allows me to use the touchpad in the EVER SO UNLIKELY event I've lost my mouse. (I hate touchpad meece!)

blacklisting psmouse certainly works, but removes the possibility of using it in a pinch easily.

I've actually added a hot-key (Win-M) to toggle the state of the touchpad, so when I'm out and about, if I need it, it's just two keys away. (rare, but does happen!)

share|improve this answer
    
That's perfect, thank you. –  DavidF Sep 29 '12 at 14:10

Depending on the version of gnome installed either this:

[ `gsettings get org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled` = false ] && gsettings set org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled true || gsettings set org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled false

or this:

gconftool-2 --toggle /desktop/gnome/peripherals/touchpad/touchpad-enabled

should toggle your touchpad on and off.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.