Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I'm logged into my account on my laptop (A Thinkpad t420 running Linux Mint 12 with Gnome 3), the mouse has a noticeably lower frame rate than when I'm at the log in screen, or even in another user account. I've been trying to get to the bottom of the problem for days.

The mouse is perfectly responsive, but it skips over most of the pixels in it's path if it's moving quickly. It's perfectly smooth in the other accounts.

  • It does not seem to be caused by the theme or any gnome-shell extensions. I have changed to other themes and changed a test account's themes and extensions to match my normal account. No difference.

  • htop does not show that any process is using too much CPU in either account. In both it was 1-4%.

  • I've played with the mouse settings in System Settings> Mouse and Touchpad but it hasn't changed the problem.

I'm pretty stumped. I suppose my next test is to remove the user account and re-create it, but I feel like I'd just mess up the mouse again and still have no idea what happened. Anyone have any ideas on how to fix it?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I got the same problem an your solution pointed me to the actual reason (for me): I had the screen magnifier always on, but with the lowest magnification, 1:1. So that way, I could change magnification fast without setting it on before and in the lowest magnification mode (1:1), the screen just looks like the normal screen.

But!

In the magnification mode (including 1:1), the mouse movement gets less smooth. (i think it always calculates which part of the screen to show.)

So for me, the solution is simply to turn off screen magnification.

share|improve this answer
    
Thanks for responding to this old problem! I very much bet that's what the problem with mine was. I had played with the magnification before, and I don't know if I had ever turned it off. I've played with a lot of settings again (After backing up my ~/.config/dconf/user file just in case) but the problem hasn't returned so far! –  Squid_Tamer Jun 18 '12 at 1:19

After a ton of trial, error, and general breaking things I figured out how to fix it. It's not a very clean way, but you have to delete "~/.config/dconf/user".

That'll pretty much reset all of your Gnome settings, so you'll have to set everything back up. I've set it all back up exactly how I had it before, and the problem has not returned, so I still have no idea what causes it to happen.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.