Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to install afpfs-ng to get access to an AFP share from my Mac. I am running Debian and am following instructions from http://unix.stackexchange.com/a/175/17242, and I get

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... no
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

Does it mean there were some issues during installation? Are there any better ways of enabling AFP access on Linux?

share|improve this question
    
Your question is not quite clear: do you want to compile afpfs-ng on a Mac or on Debian? (I assume it's the second). Please edit it. –  Renan Mar 31 '12 at 19:42
1  
I am compiling on debian, edited my question, I hope it's clear now. –  user20997 Mar 31 '12 at 19:49
add comment

2 Answers 2

On Debian there's a meta-package that contains most programs you'll need to do compilations.

apt-get build-essential

You'll also want to get the build dependancies required by afpfs-ng:

apt-get install libgcrypt-dev libfuse-dev libgmp-dev libreadline-dev libncurses-dev

(That list was obtained from http://ftp.de.debian.org/debian/pool/main/a/afpfs-ng/afpfs-ng_0.8.1-5.dsc)

share|improve this answer
add comment

configure: error: no acceptable C compiler found in $PATH

You need to install the C compiler. Try apt-get install gcc.

share|improve this answer
    
Ok, done it, when trying to compile now I get the following error configure: error: FUSE is not installed. To build without fuse, configure with '--disable-fuse' –  user20997 Mar 31 '12 at 19:50
    
You need to install the fuse-related packages. (don't have a Debian here, but try searching with apt-cache search fuse). –  Renan Mar 31 '12 at 19:51
    
I get a huge list of packages here, should I install one of these? –  user20997 Mar 31 '12 at 20:06
    
Try installing libfuse-dev. –  Renan Mar 31 '12 at 20:14
1  
Why would you say it isn't working? Looks like it installed just fine. Note: everything is installed in /usr/local directories. I suspect any of the binaries linked against /usr/local/lib/libafpclient.so.0.0.0 will require an LD_LIBRARY_PATH set or to put it in your ld.conf. –  jsbillings Apr 2 '12 at 23:36
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.