Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have read many other threads here and elsewhere but found no solution...

I'm trying to install Fedora 16 x86-64. At random points during installation I get black screens that do not go away.

I have tried adding nomodeset to the kernel options (by far the most common answer to this kind of problems) but it didn't help. I also tried it with combination of xdriver=vesa, still with no success. I also tried acpi=off, noapic, nolapic and noapictimer combined with and without nomodeset with no success.

Any suggestions?

Btw, my machine has a i7-950, 12 GB RAM, Gigabyte X58A-UD3R motherboard, an ATI 5870 graphics card (Gigabyte GV-R587UD-1GD Bios F8) and a couple of SATA hard drives.

share|improve this question
    
Can you access the machine when there is a black screeen from the network? –  Nils Mar 31 '12 at 19:49
    
@Nils no I cannot: I'm installing Fedora and the crash happens before setup has even started to write to the HDD. –  AlefSin Apr 1 '12 at 7:39
add comment

3 Answers 3

Do you mean that fedora is already installed and you can't boot it?

If so, try to boot in a safe mode(there should be an option in the grub menu) and see which errors occur. If there are no errors, try to run X-11 system by startx and see if there are some errors there. I had the same problem with the black screen and it turned out that the config file was wrong.

I've deleted the wrong line from the safe mode and then the system has booted.

share|improve this answer
    
No, I was trying to install it. The boot environment starts and I can go through the options for a few minutes before system suddenly crashes with a black screen. Still, thanks for the tips. –  AlefSin Apr 1 '12 at 7:37
    
That sounds more like a hardware problem than a problem in the installer. –  jsbillings Apr 2 '12 at 21:42
add comment

Try vga=normal as kernel-parameter during boot.

Update: This helped me once on OpenSuSE: noirqdebug. On that system the IRQ for the network device got disable because another device - using the same IRQ was not in use...

Perhaps your graphic adapter suffers the same fate.

share|improve this answer
    
Thanks, I tried it. Didn't solve my problem. –  AlefSin Apr 1 '12 at 7:35
    
@AlefSin I updated another possibility. –  Nils Apr 1 '12 at 20:18
add comment

I also had a similar problem while installing Fedora 17 on my Acer aspire laptop machine. The screen would always go black at the initial stage of install process. I found a temporal fix to this problem which enabled me to install it. Try adjusting display brightness before you start your installation. It worked for me. See http://joseblog.netau.net/tips-and-tricks/black-screen-while-installing-fedora-17.php

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.