Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I wanted to get the audio system going on Arch Linux, and I followed the very concise instruction I found on Archlinux.org, but it didn't help.

Has anyone done this personally, therefore knowing the practical shortcut? I'd be glad to know of it.

Thank you.

share|improve this question
What instructions? ALSA or Pulse? Please provide some more detail about what you tried, your system and what didn't work... – jasonwryan Mar 31 '12 at 8:29
Honestly being a newbie I don't have enough knowledge on Linux hardware drivers, all I can see at this time is that totem loads and plays a video and everything is ok except that I get no sound on my audio output jack. :-D – Haix64 Apr 1 '12 at 7:46
Work your way methodically through the ALSA page on the Arch Wiki - it should get you set up, and will at least allow you to add the required information to your question if you are still stuck. – jasonwryan Apr 1 '12 at 19:05
YEAH! installing alsa-utils and unmuting the PCM and MASTER through alsamixer made it work! Thanks sooooooo much @jasonwryan! Would you please sum it all up and write it as an answer below so I can "accept" it? – Haix64 Apr 1 '12 at 21:24
up vote 4 down vote accepted

The Arch Wiki ALSA page has comprehensive instructions on setting up sound. As the page notes:

udev will automatically probe your hardware at boot, loading the corresponding kernel module for your audio card. Therefore, your sound should already be working, but upstream sources mute all channels by default.

In most cases, therefore, all you need to do is unmute the channels by installing alsa-utils and using alsamixer. You should also make sure that you add your user(s) to the audio group.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.