Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Can't start X window because reporting can't find a valid framebuffer device.

Here is the error output below:

"X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-164.11.1.el5 ppc Red Hat, Inc.
Current Operating System: Linux scenarioa12.scenario.netfinity.com 2.6.18-194.el5 #1 SMP Tue Mar 16 22:03:12 EDT 2010 ppc64
Build Date: 06 March 2010
Build ID: xorg-x11-server 1.1.1-48.76.el5
Before reporting problems, check http://wiki.x.org to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational,(WW) warning, (EE) error, (NI) not implemented, (??)unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Mar 29 09:13:43 2012
(==) Using config file: "/root/xorg.conf"
(WW) ****INVALID IO ALLOCATION**** b: 0xf400fc00 e: 0xf400fcff correcting
(EE) end of block range 0xf3ffffff < begin 0xf4000000
(**) RADEON(0): RADEONPreInit
(EE) Unable to find a valid framebuffer device
(EE) RADEON(0): Failed to open framebuffer device, consult warnings and/or errors above for possible reasons
(you may have to look at the server log to see warnings)
Backtrace:
0: X(xf86SigHandler+0x98) [0x100a89d8]
1: [0x100344]
2: /usr/lib/xorg/modules/drivers/radeon_drv.so(RADEONPreInit+0xcb8) [0xf46fe18]
3: X(InitOutput+0xadc) [0x10066f4c]
4: X(main+0x274) [0x10027864]
5: /lib/libc.so.6 [0xfe2dde0]
6: /lib/libc.so.6 [0xfe2e020]
Fatal server error:
Caught signal 7.  Server aborting
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
  after 0 requests (0 known processed) with 0 events remaining."
And some other info may help:

Here is the configuration of xorg.conf:

console# cat /etc/X11/xorg.conf

# Xorg configuration created by pyxf86config

 Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
 EndSection

 Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
    Option      "XkbModel" "pc105"
    Option      "XkbLayout" "us"
 EndSection

 Section "Device"
    Identifier  "Videocard0"
    Driver      "vesa"
    Option      "UseFBDev" "true"
 EndSection

 Section "Screen"
    Identifier "Screen0"
    Device     "Videocard0"
    DefaultDepth     24
    SubSection "Display"
            Viewport   0 0
            Depth     24
    EndSubSection
 EndSection
share|improve this question
    
The dump says Using config file: "/root/xorg.conf" but you posted /etc/X11/xorg.conf –  charlesbridge Mar 29 '12 at 11:16
    
They got same content, thanks for reminding me, I should re-generate conf file under /etc instead of /root –  Rubix Lai Mar 31 '12 at 16:40

1 Answer 1

Are you actually using the vesa fb for your console? If so, check the perms on /dev/fb (these days a symlink to /dev/fb0 in typical cases) - you might need to chmod 666 the device node which the link points to.

In the case that you are not actually using the framebuffer/vesa console, edit the xorg.conf to use the Radeon driver (which I believe is called 'radeon' from the fglrx package). However, you may have to download this package from ATI/AMD's site -

sc.

share|improve this answer
    
Thanks for answering. No, I'm not using vesa, I just tried changing from radeon to vesa to see if it is any luck; I changed file perms of device /dev/fb0 to 666 and reset back to radeon, doesn't work, and I did upgrade the ATI package via yum. Any further suggestion? –  Rubix Lai Mar 30 '12 at 3:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.