Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a Lenovo Thinkpad T420 with Linux Mint 12 and gnome-shell on it. Its a Intel HD 3000 Graphics card in there.

When I'm at home, I have another Screen plugged in (19" 4:3) and everything works fine (Extended Desktop), except that I would like to have the Gnome 3 Bars + Shell on the right screen. Can't figure out how to do it.

Thanks in advance

share|improve this question

5 Answers 5

Open the System Settings > Displays control applet. It's not evident - at all - but you can drag the miniature of the top black panel onto the display you want to mark as primary. Panels, activity overlay and everything will migrate on that display.

share|improve this answer
    
Thanks! that worked just fine. –  Jan Schmidt Mar 28 '12 at 17:05
    
This answer was easy and worked without editing any files. –  user18345 May 2 '12 at 23:12
1  
Try as I might, I just couldn't drag the black bar. The entire panel where the black bar is would rather move around. Care to post a screencast? –  Dan Dascalescu Dec 27 '12 at 10:22
    
After setting the primary monitor via the config file, I managed to drag the black bar from the bigger display to the smaller one, but not the other way around. –  Dan Dascalescu Dec 27 '12 at 11:02
    
+1 Yes, this is the right way to do it. Thanks! –  Andrew Mao Apr 17 '13 at 21:09

The other answers are better for most cases, but I'm adding this here for completion's sake:

# shows all displays
$ xrandr
# set one of the displays to primary
$ xrandr --output <display> --primary

This method is better if you're docking or attaching your laptop to different / multiple monitors because it adjusts it on the fly. It's also a command line alternative to Elia's answer.

share|improve this answer
1  
This is the preferred method for me, because of the differences between MATE and Gnome. This works on both. –  Janis Peisenieks Feb 14 '13 at 9:48

The bars/shell are displayed on the primary monitor. You can configure which is the primary monitor through ~/.config/monitors.xml. Change the primary configuration item to yes for the monitor you want to become the primary monitor, and to no for the others.

share|improve this answer
    
xrandr --output <display> --primary works, but this method persists the indication of primary display. –  Dan Dascalescu Dec 27 '12 at 10:26

Just in case if Elia's answer doesn't work for you: you can open Settings->Displays, then select the display where the bar shouldn't be displayed and toggle it off. Panels, activity etc will migrate to the active monitor. Then you can switch on the second monitor again.

Also, take a look at this bug: "Primary Screen" selection UI is not easily discoverable.

share|improve this answer

This gentleman's link was very helpful

Has a great answer: Anyway, now you have your resolution set to whatever you need it to be. You’ll need to copy the settings file, which is located at ~/.config/monitors.xml.

That file contains your display settings. In order to proceed further, you’re going to need access to root. I’m going to assume that you’ll achieve this access with sudo. Open up a new terminal and enter the following:

sudo cp .config/monitors.xml /var/lib/gdm/.config/
sudo mkdir /etc/skel/.config
sudo cp .config/monitors.xml /etc/skel/.config/

The first line copies it over to GDM’s configuration so that GDM will display at the correct resolution. The second line creates a .config directory in your /etc/skel, and then on the third line we make another copy of your monitors.xml file into the /etc/skel/.config so that when you create new accounts, they will automatically be set up with the monitors config, thus making a seamless transition for everyone.

You should also copy that file into any existing users if they aren’t properly configured already. Never again will you have to worry about a low resolution on your high resolution display.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.