Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have been reading up on ArchBang, and I am quite interested to try it. My netbook does not have a CD/DVD drive, so I created USB installation stick using numerous Windows tools, like LiLi, and Linux tools, like UNetBootIn.

However, I never seem to succeed to the end! In the 3rd step, i.e. copying the files, I am getting endless input/output failure messages, and then my system freezes. I tried from USB to USB, and from USB to netbook HDD, and it happens in both cases and installation never ultimately succeeds.

I want it as dual boot with Windows. On my netbook, I tried it that way, by setting partitions manually lest ArchBang deletes everything. On the USB stick, I tried installing ArchBang standalone. But those input/output failures never leave me! Please help! Thanks in advance.

share|improve this question
2  
Why are you using UNetbootin? If ArchBang is packaged in the same way as the official Arch CDs, you can just dd it to the USB flash device. –  Chris Down Mar 25 '12 at 2:17
    
I also tried that. This is what I did: sudo dd if=archbang-2011.11-i686.iso of=/dev/sdb bs=8M where /dev/sdb is my USB stick. After several minutes, when it was finished, it said: 52+1 records in 52+1 records out 443547648 bytes (444 MB) copied, 68.6247 s, 6.5 MB/s But my USB stick was not even bootable and had nothing in it! What am I doing wrong? Before starting this, I formatted my USB stick and it has ext4 filesystem. Is that the right way? –  Subhamoy Sengupta Mar 25 '12 at 9:55
    
Maybe the USB stick is damaged? That might explain the I/O errors and why not even the dd works (btw, formatting partitions on it before doing the dd doesn't matter, as the goal of dd is to copy an image, that will overwrite whatever filesystem is on the stick -- if it's a CD image (as its name suggests), you will probably end up with an iso9660 filesystem (plus the not that obvious but essential El Torito parts)) –  njsg Mar 25 '12 at 18:47
1  
Thank you both for the good suggestions! I deleted all filesystems on the USB stick and tried dd again and this time it indeed created an iso 9660 filesystem and it installed. It could not find Windows though, so now GRUB needs to be manually configured. Thanks again! –  Subhamoy Sengupta Mar 26 '12 at 17:18
    
you can do that easely by going to /boot/grub/menu.lst and uncommenting the windows line. Make sure you have chainloader +1 set for windows 7 and also make sure that the correct partition is given. You can view your partitions with cfdisk for example which can show you the labels so you know which is which. –  Silverrocker Jun 19 '12 at 23:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.