Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Successfully installed Gnome3 on archlinux (not the fallback mode).

EDIT: My wired internet connection works fine.

However, I can't see the network icon (or wireless networks) in the tray. When I open Network Connections from Gnome3 the Wired and Wireless tabs are empty.

I think I tried everything I could think of:

  1. putting network-manager in DAEMONS in rc.conf and relogging, but nothing happens.
  2. installing network-manager-applet
  3. Googling, but threads like these leave much to be desired.

Any help appreciated.

share|improve this question
    
Some information about your wireless card and firmware would help diagnose your issue. Have you tried setting it up manually as per the Arch Wiki? –  jasonwryan Mar 24 '12 at 8:53
2  
So what's exactly the issue you are trying to address? That the tool you used to use in order to check networking status and set up new connections is not showing up anymore, or that the network device is not working anymore? In case you, yourself, are not sure, please check first if the network device is being detected (kernel log, dmesg; PCI and USB device lists lspci, lsusb; network device lists ifconfig and iwconfig). Problems with a GUI tool not showing the right thing are completely different from lack of device support. –  njsg Mar 24 '12 at 9:15
    
@jasonwryan I followed the wiki (my card is Intel Ultimate-N 5300 ) - but there is no actual "setup" in it. The drivers for my chipset "have been supported since kernel 2.6.27". –  drozzy Mar 24 '12 at 16:43
    
@njsg My wired internet works, but my wireless - I don't know how to set-it up. The Gnome's Network Connections Dialog shows no wireless OR wired connections. I'll run the commands you provided when I get home, thank you. –  drozzy Mar 24 '12 at 16:46
    
@njsg When running lspci I can see my wireless Intel Corporation Ultimate N Wifi Link 5300 in the list. –  drozzy Mar 24 '12 at 19:51
add comment

1 Answer

up vote 3 down vote accepted

As always, the problem was with no finishing the reading of documentation.

I needed to actually run NetworkManager (gnome automatically picks it up), and disable archlinux's network daemon. It's all here: https://wiki.archlinux.org/index.php/NetworkManager#Configuration

NOTE: You can start daemon manually by running:

sudo /etc/rc.d/networkmanager
share|improve this answer
    
Please accept your answer if the issue is resolved. –  sastanin Apr 5 '12 at 15:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.