Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have installed VMware Player on my Debian squueze, but after the reboot the vmware daemon(/etc/init.d/vmware) does not start up automatically, i have tried without any success to set the daemon startup with insserv :

insserv vmware 

but it gives me the following output :

insserv: warning: script 'K01vpnclient_init' missing LSB tags and overrides
insserv: warning: current start runlevel(s) (2) of script `vmware' overwrites defaults (2 3 5).
insserv: warning: current stop runlevel(s) (0 3 5 6) of script `vmware' overwrites defaults (2 3 5).
insserv: warning: script 'vpnclient_init' missing LSB tags and overrides
insserv: script vboxdrv: service vboxdrv already provided!

and it doesn't work ... Why ? How can i solve the problem ?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

LSB tags are the "Linux Standard Base" script headers that tell insserv and chkconfig how to create the companion rc.? scripts. You have to create a LSB header and re-run insserv

Edit:

Rather after actually taking the time to look at all your information it may have the LSB header but not configured correctly. Search for LSB init scripts and there are several links out there. You have to either configure the LSB header better or differently, or you have to add additional information like the source of the LSB functions.

Also, it looks like the header might have been configured for RH or SUSE based distros given that it is starting in 2,3,5. You have some conflicting settings listed in your insserv line.

Edit 2:

If you don't mind could you put the first 20 or so lines of the /etc/init.d/vmware init script into your question. Thanks

Edit 3: Links

Debian Wiki: How to LSBize an Init Script

The Geek Stuff: How to Write Linux Init Scripts Based on LSB Init Standard

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.