Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Here is what I currently have online, as you can see there is no information about my debian server.

(While was installing I tried to follow next instructions)

What I have changed in default gmond.conf:

cluster {
  name = "dspproc"
  owner = "unspecified"
  latlong = "unspecified"
  url = "dspproc"
}

udp_send_channel {
  mcast_join = 127.0.0.1
  port = 8649
  ttl = 1
}

udp_recv_channel {
  mcast_join = 127.0.0.1
  port = 8649
  bind = 127.0.0.1
}

And this is what I changed in gmetad.conf:

data_source "dspproc" 10 127.0.0.1
authority "http://195.19.243.13/ganglia/"
trusted_hosts 127.0.0.1 195.19.243.13
case_sensitive_hostnames 0

My question is: what I do wrong , and how to make ganglia show info about current machine its installed on?

Update Following this answer Changed to:

   udp_send_channel {
      host = 127.0.0.1
      port = 8649
      ttl = 1
    }

    /* You can specify as many udp_recv_channels as you like as well. */
    udp_recv_channel {
      host = 127.0.0.1 /* line 41 */
      port = 8649
      bind = 127.0.0.1
    }

got this on restart:

Starting Ganglia Monitor Daemon: /etc/ganglia/gmond.conf:41: no such option 'host'

and still Hosts up: 0 in web ui.

Upadate 2:

So... when I read the answer again and went on to the link made next changes into configuration and all worked out!) Thank you noffle!

Now that block of gmod.conf looks like

    udp_send_channel {
      host = 127.0.0.1
      port = 8649
      ttl = 1
    }

  udp_recv_channel {
    port = 8649
    family = inet4
  }
  udp_recv_channel {
    port = 8649
    family = inet6
  }

and all seems to work...

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I seem to remember having a similar problem when setting up Ganglia many moons ago. This may not be the same issue, but for me it was that my box/network didn't like Ganglia's multicasting. Once I set it up to use unicasting, all was well.

From the Ganglia docs:

If only a host and port are specified then gmond will send unicast UDP messages to the hosts specified.

Perhaps try replacing the mcast_join = 127.0.0.1 with host = 127.0.0.1.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.