Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I installed a Centos 6.2 min install. I have edited /etc/sysconfig/network-scripts and I have ifcfg-eth0,eth1

I have tried to setup static IPs but I only get IPV6 address back on both adapters and can't ping anything since the rest of the network is IPV4.

I have copied my working settings from another Centos 6 server I have setup and working. Not sure what to do next?

I already added a line to say NETWORKING_IPV6=no

share|improve this question
    
Please post the ifcfg scripts so we can take a look! Is your network manager set to IPV6 (if it's installed)? If network manager is running, it'll override your static settings unless you explicitly say to not manage the interface. –  FloppyDisk Mar 20 '12 at 11:19
add comment

1 Answer 1

Something along the lines of this in your ifcfg-eth0 file should work:

DEVICE=eth0
ONBOOT=yes
NETMASK=255.255.255.0
IPADDR=192.168.0.10
TYPE=Ethernet

If you're having trouble, posting your network scripts would be helpful.

share|improve this answer
    
I will try that when I get home and let you know thanks. I have edited in and out so many times. Was starting to think problem with 6.2??? Used same settings as my other working server 6.0, and didnt work. –  Rodger Bruce Mar 21 '12 at 20:39
    
ok mine is just like your except i have hardware= for network adapter that was already there. I also have a gateway and 2 dns addresses defined. still not working. –  Rodger Bruce Mar 22 '12 at 0:35
    
I have tried editing also probmode.conf files as some suggested along with network file. Im at the point of reinstalling with Centos 6.0 instead of 6.2. I have a 6.0 version running fine with static ipv4 no problems. –  Rodger Bruce Mar 22 '12 at 23:03
    
Loaded Centos 6.0 network adapters working fine ipv4. –  Rodger Bruce Mar 23 '12 at 2:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.