Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

For me to connect to internet I need to login first. Normally I do this manually (by opening my browser then at the first URL I enter I am redirected to the ISP's login page). However there is a Perl script that does this automatically (each time the PC is booted). How do I make use of this script? (Where and how do I tell Debian to use this script)

note: i use network-manager.

share|improve this question
    
Are you using NetworkManager, wicd, ifupdown (/etc/network/interfaces) or something else to connect? –  jofel Mar 17 '12 at 23:36
    
@jofel: Why don't you make this an answer? –  user unknown Mar 18 '12 at 6:24
add comment

1 Answer 1

You need a post-connection script for wicd. You can set it in /etc/wicd/wireless-settings.conf or /etc/wicd/wired-settings. Another way is to use wicd-gtk: there is a "Scripts" button in the network's settings page.

Another way is to put the script into /etc/wicd/scripts/postconnect/. Then it should be run automatically after every connection to a network.

For more information, see here.

share|improve this answer
    
ok, i need a bit of help here, what i have done so far: -my script is called firewall.pl and i copied it to /etc/wicd/scripts/postconnect and made it executable (by doing chmod +x). -i opened the gui and entered the params: i.imgur.com/khIVx.png -booted my pc, but no dice. apparently the script isn't being run by wicd for i still have to manually login. what am i doing wrong? –  sterz Mar 20 '12 at 21:06
    
@sterz My answer was not 100% complete, I'll edit it: Either put the script into /etc/wicd/scripts/*/ or set it in the settings of the particular connection, where you need the full path to the script. The arguments wired etc. are added to the command line by wicd automatically, so you do not need to specify them. Have you tried to call the script by hand? –  jofel Mar 20 '12 at 21:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.