Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I accidentally removed i32-libs using the following command

      sudo apt-get remove ia32-libs

Now the GUI is not working properly: when I login, it just shows me a small terminal on one side of the screen, and nothing on the rest of the desktop. I ran

sudo apt-get install ubuntu-desktop

and I tried choosing a different session type on the login screen; if I select “Ubuntu classic mode” the desktop is fine but some applications still fail; for example when I start Skype, I see the message

skype: error while loading shared libraries: libXss.so.1: wrong ELF class: ELFCLASS64
share|improve this question
    
sudo apt-get install ia32-libs? –  pbm Mar 17 '12 at 20:52
    
@pbm did this... gui is still bad –  Shan Mar 17 '12 at 20:54
    
What is exactly wrong? Could you post screenshot? –  pbm Mar 17 '12 at 21:17
    
@pbm tried that... cant get it nothing is working... –  Shan Mar 17 '12 at 21:26
    
I did sudo apt-get install ubuntu-desktop... after that it shows me the lastest gui login... when I login it just shows me a small terminal on one side of the screen and nothing and rest id the desktop with nothing on it –  Shan Mar 17 '12 at 21:28

1 Answer 1

Judging from the skype error, it is expecting a 32-bit library but only found a 64-bit one. iirc ia32-libs is a package containing 32-bit libraries needed for running 32-bit programs in a 64-bit environment. Since you accidentally removed it, i would just reinstall ia32-libs to try to resolve that error.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.