Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'll start off that I'm new to Linux. A couple months ago I tried installing Ubuntu 11.10 on a laptop (HP). The install went great, however when setting up my wireless network, it caused my router (Buffalo) to crash. I could not login to the routers http interface even on a wired PC. I removed power from the router and shutdown the laptop. Powered the router back up. Everything worked on the network again. I powered the laptop again and the router crashed again. The router had been working fine for months and has worked great since trying. It has the following firmware: DD-WRT v24SP2-EU-US (08/19/10) std.

I tried to install Mint 12 last night with the exact same issue. I turned off wireless on the laptop and plugged it into the router. I was able to update so Mint tells me I have all updates applied.

I Googled a bit and found people stating to move your wireless router to bg only. I tried that with a little luck. I was able to browse the internet for ~10 minutes on wireless before the router crashed. Again replugging the router fixed the problem and without powering up the laptop the router has been solid today.

share|improve this question

I did some more Googling and found found this post


It does seem to fix my issue.

echo "options iwlagn 11n_disable=1" | sudo tee /etc/modprobe.d/iwlagn.conf
sudo modprobe -rf iwlagn
sudo modprobe -v iwlagn
sudo service network-manager restart

I do still have my router set to BG only. I will try allowing N, but it is working for now.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.