Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Yesterday I upgraded my debian laptop with the backports repository. Amongst the packages it installed, a new kernel was added (3.2.0). When booting on this kernel, the right-click on my mouse pad (is it called that way?) doesn't work. I tried booting on my old kernel (2.6.39) and it works like a charm.

I have a bunch of live CDs for various distros lying around on my desk, so I tried launching live sessions. It confirmed my idea that it is a kernel issue. My hardware doesn't work well with recent kernels.

My question is not how to solve my particular problem (I'm not even giving details about my hardware). What's the way to go when facing such a problem? Can anyone point me to good documentation?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.