Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm having problems to update to the latest version of particular software on Debian. I'm using Debian 6.0.4 and I currently I have Shutter version 0.85 which is currently the latest stable version.

I have this line in sources.list:

deb http://backports.debian.org/debian-backports squeeze-backports main

and I run the command

apt-get -t squeeze-backports install shutter

and all I get is that it installs the same 0.85 version. I know there is a unstable version 0.88 and I would really like to get it somehow.

Thanks for any help

share|improve this question

2 Answers 2

Shutter is that rarity, a package with no build dependencies, except debhelper >= 7, which doesn't count. The runtime dependencies are all in squeeze. Complete transcript follows. This assumes you have deb-src lines for testing or unstable in /etc/apt/sources.lst.

faheem@orwell:/usr/local/src$ apt-cache showsrc shutter
[...]    
Package: shutter
Binary: shutter
Version: 0.88.1-1
Maintainer: Ryan Niebur <ryan@debian.org>
Build-Depends: debhelper (>= 7.0.50)
[...]
faheem@orwell:/usr/local/src$ apt-cache policy shutter
shutter:
  Installed: 0.88.1-1
  Candidate: 0.88.1-1
  Version table:
     0.88.1-1 0
         50 http://debian.csail.mit.edu/debian/ testing/main i386 Packages
         50 http://debian.csail.mit.edu/debian/ unstable/main i386 Packages
     0.85.1-2 0
        500 http://debian.csail.mit.edu/debian/ squeeze/main i386 Packages

faheem@orwell:/usr/local/src$ mkdir shutter
faheem@orwell:/usr/local/src$ cd shutter/
faheem@orwell:/usr/local/src/shutter$ apt-get source shutter
Reading package lists... Done
Building dependency tree       
Reading state information... Done
NOTICE: 'shutter' packaging is maintained in the 'Git' version control system at:
git://git.debian.org/git/collab-maint/shutter.git
Need to get 3,027 kB of source archives.
Get:1 http://debian.csail.mit.edu/debian/ testing/main shutter 0.88.1-1 (dsc) [1,149 B]
Get:2 http://debian.csail.mit.edu/debian/ testing/main shutter 0.88.1-1 (tar) [3,022 kB]
Get:3 http://debian.csail.mit.edu/debian/ testing/main shutter 0.88.1-1 (diff) [4,123 B]                                                                           
Fetched 3,027 kB in 1min 41s (29.7 kB/s)                                                                                                                           
gpgv: keyblock resource `/home/faheem/.gnupg/trustedkeys.gpg': file open error
gpgv: Signature made Mon 12 Dec 2011 01:06:01 PM IST using DSA key ID F69C6AC5
gpgv: Can't check signature: public key not found
dpkg-source: warning: failed to verify signature on ./shutter_0.88.1-1.dsc
dpkg-source: info: extracting shutter in shutter-0.88.1
dpkg-source: info: unpacking shutter_0.88.1.orig.tar.gz
dpkg-source: info: unpacking shutter_0.88.1-1.debian.tar.gz
faheem@orwell:/usr/local/src/shutter$ cd shutter-0.88.1/
faheem@orwell:/usr/local/src/shutter/shutter-0.88.1$ debuild binary
[...]
dpkg-deb: building package `shutter' in `../shutter_0.88.1-1_all.deb'.
faheem@orwell:/usr/local/src/shutter/shutter-0.88.1$ cd ..
faheem@orwell:/usr/local/src/shutter$ sudo dpkg -i shutter_0.88.1-1_all.deb 
[sudo] password for faheem: 
Selecting previously deselected package shutter.
(Reading database ... 365531 files and directories currently installed.)
Unpacking shutter (from shutter_0.88.1-1_all.deb) ...
dpkg: dependency problems prevent configuration of shutter:
 shutter depends on libgnome2-wnck-perl; however:
  Package libgnome2-wnck-perl is not installed.
 [bunch of missing dependency errors omitted]
faheem@orwell:/usr/local/src/shutter$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libcommon-sense-perl libfile-basedir-perl libfile-which-perl libgnome2-gconf-perl libgnome2-wnck-perl libgtk2-imageview-perl libgtk2-unique-perl
  libgtkimageview0 libjson-perl libjson-xs-perl libpath-class-perl libproc-processtable-perl libproc-simple-perl libsort-naturally-perl libx11-protocol-perl
  perlmagick
Suggested packages:
  imagemagick-doc
The following NEW packages will be installed:
  libcommon-sense-perl libfile-basedir-perl libfile-which-perl libgnome2-gconf-perl libgnome2-wnck-perl libgtk2-imageview-perl libgtk2-unique-perl
  libgtkimageview0 libjson-perl libjson-xs-perl libpath-class-perl libproc-processtable-perl libproc-simple-perl libsort-naturally-perl libx11-protocol-perl
  perlmagick
0 upgraded, 16 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 1,063 kB of archives.
After this operation, 3,731 kB of additional disk space will be used.
Do you want to continue [Y/n]? 
Get:1 http://debian.csail.mit.edu/debian/ squeeze/main libgnome2-wnck-perl i386 0.16-2 [91.0 kB]
Get:2 http://security.debian.org/ squeeze/updates/main perlmagick i386 8:6.6.0.4-3+squeeze1 [220 kB]
Get:3 http://debian.csail.mit.edu/debian/ squeeze/main libgnome2-gconf-perl i386 1.044-3 [103 kB]
Get:4 http://debian.csail.mit.edu/debian/ squeeze/main libx11-protocol-perl all 0.56-2 [161 kB]                                                                    
Get:5 http://debian.csail.mit.edu/debian/ squeeze/main libfile-basedir-perl all 0.03-1 [10.4 kB]                                                                   
Get:6 http://debian.csail.mit.edu/debian/ squeeze/main libproc-simple-perl all 1.26-2 [16.9 kB]                                                                    
Get:7 http://debian.csail.mit.edu/debian/ squeeze/main libfile-which-perl all 1.08-1 [12.7 kB]                                                                     
Get:8 http://debian.csail.mit.edu/debian/ squeeze/main libsort-naturally-perl all 1.02-1 [14.3 kB]                                                                 
Get:9 http://debian.csail.mit.edu/debian/ squeeze/main libgtkimageview0 i386 1.6.4-1 [29.5 kB]                                                                     
Get:10 http://debian.csail.mit.edu/debian/ squeeze/main libgtk2-imageview-perl i386 0.05-1 [81.3 kB]                                                               
Get:11 http://debian.csail.mit.edu/debian/ squeeze/main libgtk2-unique-perl i386 0.04-1 [42.0 kB]                                                                  
Get:12 http://debian.csail.mit.edu/debian/ squeeze/main libproc-processtable-perl i386 0.45-1 [48.6 kB]                                                            
Get:13 http://debian.csail.mit.edu/debian/ squeeze/main libpath-class-perl all 0.19-1 [34.8 kB]                                                                    
Get:14 http://debian.csail.mit.edu/debian/ squeeze/main libjson-perl all 2.21-1 [85.7 kB]                                                                          
Get:15 http://debian.csail.mit.edu/debian/ squeeze/main libcommon-sense-perl all 3.3-1 [21.8 kB]                                                                   
Get:16 http://debian.csail.mit.edu/debian/ squeeze/main libjson-xs-perl i386 2.290-1 [91.0 kB]                                                                     
Fetched 1,063 kB in 32s (32.3 kB/s)                                                                  
[...]
Setting up shutter (0.88.1-1) ...

faheem@orwell:/usr/local/src/shutter$ apt-cache policy shutter
shutter:
  Installed: 0.88.1-1
  Candidate: 0.88.1-1
  Version table:
     0.88.1-1 0
         50 http://debian.csail.mit.edu/debian/ testing/main i386 Packages
         50 http://debian.csail.mit.edu/debian/ unstable/main i386 Packages
 *** 0.88.1-1 0
        100 /var/lib/dpkg/status
     0.85.1-2 0
        500 http://debian.csail.mit.edu/debian/ squeeze/main i386 Packages
share|improve this answer
    
sh: dpkg-source: not found Unpack command 'dpkg-source -x shutter_0.88.1-1.dsc' failed. Check if the 'dpkg-dev' package is installed. –  user1089548 Mar 13 '12 at 10:51
    
thanks a lot for this, I get the error above with dpkg-dev, and when I try to install it says: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. –  user1089548 Mar 13 '12 at 10:52
    
and this: The following information may help to resolve the situation: The following packages have unmet dependencies: initscripts : Breaks: console-setup (< 1.74) but 1.68+squeeze2 is to be installed Breaks: nfs-common (< 1:1.2.5-3) but 1:1.2.2-4squeeze2 is to be installed network-manager : Recommends: crda but it is not going to be installed Breaks: network-manager-gnome (< 0.9) but 0.8.1-2 is to be installed E: Broken packages –  user1089548 Mar 13 '12 at 10:53
    
@user1089548: You probably have accidentally mixed packages across different versions. Check apt-cache policy for all the packages mentioned in the errors. You should check your /etc/apt/sources.list and your /etc/apt/preferences. See also man apt_preferences. –  Faheem Mitha Mar 13 '12 at 12:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.