Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have problem with Network Manager in xmonad. Let's say I want to connect to a new wireless network. When I try to do so, error is displayed, saying: "insufficient privileges". But when I try do do this with Gnome 3 there is no problem. And, when new network is added (using Gnome), I can now connect to this network when I am using xmonad.

I use Debian Sid, with 3.2.0-1-486 kernel, latest (0.10) version of xmonad. In xmonad, I use NetworkManager applet (

Part of my .xsession:

gnome-screensaver &
gnome-settings-daemon &
if [ -x /usr/bin/nm-applet ] ; then
    nm-applet --sm-disable &
update-notifier &
exec xmonad

I suppose that I should add something to .xsession, but I am not sure about that.

I hope that you can give me some clues and maybe even a solution. Thank you.

share|improve this question

I had similar problems with NetworkManager under AwesomeWM (sic!) (on a Ubuntu 11.10 system).

After fixing other permission related stuff I noticed that NM applet also needs a ConsoleKit session.

To check if this also your problem you can start the NM applet like this:

$ ck-launch-session nm-applet

(for testing purposes you can start it from an xterm)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.