Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm attempting to connect to my Arch server running tmux from my work Windows PC. I've found that while Console2 does a decent job with most things, it's not perfect, and I get all sorts of graphical glitches (fault of my semi-complex configurations).

I'd like to use rxvt to keep things simple (I'd rather not have the overhead of an X server for rxvt-unicode). However, when I split windows in tmux, the borders appear as a set of garbage bytes that are represented as €â”.

Is it possible to have a regular border when using tmux and rxvt (non-unicode)?

Thanks!

share|improve this question
    
This sounds like an character encoding issue. What is your system character encoding? –  Chris Down Mar 9 '12 at 14:17
    
Since I'm using the Consolas font, I believe Windows has UTF8 available. My server is set to UTF8 as well, and I haven't defined any encoding changes to tmux... –  Tammer Ibrahim Mar 9 '12 at 15:18
    
It may be available, but whether it is actually enabled is another matter. –  Chris Down Mar 9 '12 at 15:39
    
Ah I see... so regular old rxvt should be capable of displaying those UTF8 characters? –  Tammer Ibrahim Mar 9 '12 at 15:41
add comment

1 Answer

up vote 1 down vote accepted

I can't explain €â”, I would have expected │ which is the Windows-1252 interpretation of the bytes that encode in UTF-8. is what Tmux uses for vertical borders between windows. But you evidently have an encoding mismatch.

Run locale to see what your locale settings are. The Windows native port of Rxvt in Cygwin doesn't support UTF-8, so you need to set an 8-bit locale. Specifically, the LC_CTYPE category must not end in utf8 (or utf-8 or UTF8 or UTF-8).

The real solution is to use MinTTY (it's shipped with Cygwin) or PuTTYcyg. Both are derived from PuTTY and support UTF-8. See also How do you configure a Windows machine for a Linux user?

share|improve this answer
    
Thanks for the full answer! I'll have to investigate the particular encoding problems at a later date, as getting MinTTY set up was quite simple. (I would have tried it first, but I've got a terrible allergy to windows-only software!) –  Tammer Ibrahim Mar 12 '12 at 14:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.