Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've recently installed Linux Mint 12 ("Lisa", i.e. not the KDE or Debian version) on a Zotac Mini-PC (Which has an AMD Video card. I'm not using the proprietary drivers as they don't work very well). Almost immediately after this, I decided to use Xfce 4.8 instead of GNOME so I found a build/install script to grab everything it needs and install it.

Everything seems to work fine except I have just noticed that Terminal will re-size itself when it launches. First it will shrink horizontally until you can just see the caret position in the Terminal window. The height of the window does not change from what it is when it initially opens up.

After you try to change the size of the Terminal window, it will again re-size itself horizontally but shrink vertically as well. Subsequent attempts at changing the window size produce "random" results - sometimes it will start shrinking in both directions, sometimes it won't shrink. I also occasionally see a video stutter, as if the Terminal is trying to stay at the height and width it was at is but is being forced to shrink.

What gives? I suspect it might be an issue with GTK 2.x (which I believe Xfce 4.8 uses) and GNOME 3 which uses GTK 3, but why would these processes be running at the same time if I'm not currently in a GNOME session? I'm no Linux expert by any stretch of imagination...

XTerm doesn't seem to have this issue. The terminal I'm referring to is "Terminal Emulator" run by: "exo-open --launch TerminalEmulator"

Any ideas?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Check in Settings > Preferred Applications, under the utilities tab to see exactly which terminal program is being run by exo-open. I suspect that it's gnome-terminal, for which this is a known bug. The fix landed pretty recently, so maybe it's not in your distribution (even though Mint 12 just came out). Alternately, maybe the fix doesn't completely address the problem in some circumstances.

As a workaround, try switching to XFCE Terminal (a.k.a just Terminal, with a capital T). This has its own set of bugs, but at least not this one.

share|improve this answer
    
Thanks very much. It definitely was the gnome terminal and installed Terminal instead. –  Dalin Seivewright Mar 9 '12 at 23:39
    
I find that when i resize gnome-terminal and click away from it, the terminal autoresizes itself to the previous size. The workaround I have until this is fixed is to have another terminal tab open (which I always have anyways), then click or tab to it and then the resizing doesn't happen. –  yuvilio May 9 '13 at 14:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.