Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My system is running Fedora 16 and I live in a campus where we use LAN to connect to the Internet. And for this, we use an http proxy with authentication (username & password). I tried putting the proxyaddress:port in the Network Proxy settings after going to the Network Settings window. However, it never asked for an authentication and the programs that use the internet are unable connect, except for Firefox because it asks for authentication. Also, I could get Yum to work by manually editing yum.conf. I even tried using http://username:password@proxy:port like in the Yum configuration but it has not helped.

Is there any solution to this problem?

Thank you.

share|improve this question

migrated from serverfault.com Mar 7 '12 at 14:28

This question came from our site for professional system and network administrators.

    
The GNOME manual mentions a Details button in Network Proxy settings, have you tried this? –  sr_ Mar 8 '12 at 8:42
    
Unfortunately, there is no such Details button. Atleast not in Fedora 16. –  Vishnu Mar 8 '12 at 11:23

1 Answer 1

up vote 1 down vote accepted

Many, but not all, programs honor the environment variables http_proxy, https_proxy, ftp_proxy, and no_proxy. You could add them to your ~/.bashrc .

export http_proxy="http://username:password@yourproxy:port"
export https_proxy="http://username:password@yourproxy:port"
export ftp_proxy="http://username:password@yourproxy:port"
export no_proxy="localhost,127.0.0.1"

Some programs, like yum, will require the proxy information in a certain way and will need to be configured on an individual basis.

It's also possible to manually set proxy settings in Gnome3 by using gsettings because some programs, like Chromium, will honor those settings. See man gsettings and gsettings help for more information.

# gsettings list-recursively org.gnome.system.proxy
org.gnome.system.proxy autoconfig-url ''
org.gnome.system.proxy ignore-hosts ['localhost', '127.0.0.0/8']
org.gnome.system.proxy mode 'none'
org.gnome.system.proxy use-same-proxy true
org.gnome.system.proxy.ftp host ''
org.gnome.system.proxy.ftp port 0
org.gnome.system.proxy.http authentication-password ''
org.gnome.system.proxy.http authentication-user ''
org.gnome.system.proxy.http enabled false
org.gnome.system.proxy.http host ''
org.gnome.system.proxy.http port 8080
org.gnome.system.proxy.http use-authentication false
org.gnome.system.proxy.https host ''
org.gnome.system.proxy.https port 0
org.gnome.system.proxy.socks host ''
org.gnome.system.proxy.socks port 0
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.