Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Recently I bought this disk and I cannot get rid of funny clicking -- funny because normally not configured disk make dry click.

This one make click like a sweet chirp. But besides this, this click occurs every several seconds, and it is annoying.

I tried as usual: hdparm -B 254 but it changed nothing.

So does anyone know how to disable that clicking?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

This is a known issue and the fix is here:

http://forums.seagate.com/t5/Barracuda-XT-Barracuda-Barracuda/ANNOUNCEMENT-New-firmware-update-for-Barracuda-1TB-platter/td-p/162362

share|improve this answer
    
Thank you. For other readers -- basically it is (finally) newer firmware. However setup is only for Mac or Windows, not Linux. –  greenoldman Apr 21 '13 at 8:15

A hard drive should not produce any clicking sounds. Especially because you describe the sounds as funny I assume that the sounds are unusual and therefore the drive is not operating correctly. Your data might be in danger.

I would immediately back up the data and send it back for warranty (you can wipe it before if your data is confidential).

share|improve this answer
    
No, this is pretty normal, unfortunately. Every disk I bought recently required this tweak with disabling parking heads. The only difference is, the pitch now is different, and I cannot disable it (the second is most important). But since this is my first 3TB disk, with 3 platters, I assume that such side effect as pitch could differ after all. –  greenoldman Mar 6 '12 at 22:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.