Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm playing around with Linux Mint Debian Edition (LMDE) in a VirtualBox instance to try it out and see if it'd be good for a main operating system for me. I'm pretty competent with most system administration and I'd like to have something like LMDE which is based on Debian testing so I can have a much more living/up to date operating system than Ubuntu/Linux Mint which is what I've historically run in the past. Something about reinstalling my operating system every 6 months to keep up to date seems wrong to me.

After installing a virtual LMDE and apt-get update and apt-get dist-upgrade, I got the following error:

Reading package lists...
Building dependency tree...
Reading state information...
The following packages will be REMOVED:
  gstreamer0.10-plugins-really-bad libntfs-3g75 libntfs-3g804 libvlccore4 vlc
  vlc-nox vlc-plugin-notify vlc-plugin-pulse
The following NEW packages will be installed:
  cpp-4.5 gcc-4.5 gcc-4.5-base gcj-4.6-base gcj-4.6-jre-lib gir1.2-peas-1.0
  gnome-desktop3-data libaacplus2 libaacs0 libbluray-bdj libbluray1
  libcrystalhd3 libelfg0 libevince3 libgail-3-0 libgcj-bc libgcj-common
  libgcj12 libgdata1.8-cil libglew1.6 libgnome-desktop-3-0 libjaxp1.3-java
  libjaxp1.3-java-gcj liblockfile-bin libmhash2 libmission-control-plugins0
  libmtp-runtime libmtp9 libpeas-1.0-0 libpeas-common libpoppler-glib6
  libpoppler13 libseed-gtk3-0 libsigsegv2 libvlccore5 libwebkitgtk-3.0-0
  libwebkitgtk-3.0-common libxalan2-java libxalan2-java-gcj libxerces2-java
  libxerces2-java-gcj linux-headers-3.0.0-1-amd64 linux-headers-3.0.0-1-common
  linux-headers-amd64 linux-image-3.0.0-1-amd64 linux-image-amd64
  linux-kbuild-3.0.0 poppler-data zenity-common
The following packages have been kept back:
  foomatic-db-engine gstreamer0.10-ffmpeg libavcodec53 mplayer
The following packages will be upgraded:
  acpid alsa-utils apt apt-file apt-utils aspell aspell-en banshee base-passwd
  bc binfmt-support brasero brasero-common bsdutils busybox cpp-4.4
  cpufrequtils cron cups cups-client cups-common cups-driver-gutenprint
  cups-ppdc curl dc dkms dmsetup eog evince evince-common fakeroot
  firmware-atheros firmware-bnx2 firmware-bnx2x firmware-intelwimax
  firmware-ipw2x00 firmware-ivtv firmware-iwlwifi firmware-linux
  firmware-linux-nonfree firmware-qlogic firmware-ralink firmware-realtek
  foomatic-db foomatic-filters fortunes-husse fuse fuse-utils g++-4.4 gawk
  gcc-4.4 gcc-4.4-base gconf-editor genisoimage gettext-base gimp
  gir1.2-gdkpixbuf-2.0 gir1.2-gtk-3.0 gnome-applets gnome-applets-data
  gnome-bluetooth gnome-disk-utility gnome-nettool gnome-power-manager
  gnome-user-share grep grub-common grub-pc grub-pc-bin grub2-common
  gstreamer0.10-plugins-bad gzip hal hwdata iptables iso-codes jfsutils
  klibc-utils libalgorithm-diff-xs-perl libapache2-mod-dnssd libarchive1
  libart2.0-cil libaspell15 libaudio2 libavutil51 libblas3gf libbrasero-media0
  libbs2b0 libburn4 libcap2-bin libcpufreq0 libcupscgi1 libcupsdriver1
  libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3 libdevmapper1.02.1 libedit2
  libenchant1c2a libencode-locale-perl libevolution libfaac0 libfuse2
  libgconf2.0-cil libgdiplus libgdu-gtk0 libgdu0 libgimp2.0 libglade2.0-cil
  libglib-perl libglib2.0-cil libglu1-mesa libgnome-bluetooth7
  libgnome-vfs2.0-cil libgnome2.24-cil libgnomecanvas2-0
  libgnomecanvas2-common libgnomepanel2.24-cil libgnomeui-0 libgnomeui-common
  libgstfarsight0.10-0 libgtk2.0-cil libgtkmm-2.4-1c2a libgudev-1.0-0
  libgutenprint2 libhal-storage1 libhal1 libhtml-format-perl
  libhtml-template-perl libieee1284-3 libijs-0.35 libisofs6 libjpeg62
  libjs-jquery libkarma0 libklibc libkpathsea5 liblapack3gf liblcms1
  liblist-moreutils-perl liblocale-gettext-perl liblockfile1 liblua5.1-0
  liblvm2app2.2 liblzma2 liblzo2-2 libmjpegtools-2.0-0 libmng1
  libmono-addins-gui0.2-cil libmono-addins0.2-cil libmpfr4 libmtp-common
  libnotify-bin libnspr4-0d libnss3-1d liboobs-1-4 libparted0debian1 libpci3
  libpcre3 libpcsclite1 libplist1 libpolkit-agent-1-0 libpolkit-backend-1-0
  libpolkit-gobject-1-0 libpolkit-gtk-1-0 libportaudio2 libpurple-bin
  libpurple0 libraptor2-0 librasqal3 librecode0 libreoffice libreoffice-base
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-emailmerge libreoffice-filter-mobiledev
  libreoffice-gnome libreoffice-gtk libreoffice-impress
  libreoffice-java-common libreoffice-math libreoffice-report-builder-bin
  libreoffice-style-galaxy libreoffice-style-tango libreoffice-writer
  libruby1.8 libsane libsane-common libsgutils2-2 libsmbclient
  libsoup-gnome2.4-1 libsqlite0 libssh2-1 libstdc++6-4.4-dev libswscale2
  libtalloc2 libtdb1 libtelepathy-glib0 libtext-charwidth-perl
  libtext-iconv-perl liburi-perl libusb-1.0-0 libv4l-0 libvlc5 libwbclient0
  libwmf0.2-7 libxapian22 libxml2-utils libxslt1.1 libxv1 libyajl1
  linux-headers-2.6-amd64 linux-image-2.6-amd64 locales m4 man-db manpages
  manpages-dev mesa-utils mint-meta-codecs mintbackup mintmenu
  mintupdate-debian mintwelcome mobile-broadband-provider-info modemmanager
  multiarch-support nautilus-share net-tools network-manager-gnome
  notification-daemon ntfs-3g ntp openssh-client p7zip p7zip-full pciutils
  pidgin pidgin-data policykit-1 policykit-1-gnome poppler-utils procps
  python-bugbuddy python-chardet python-debian python-evolution
  python-gnomeapplet python-gnomedesktop python-gnomekeyring python-gtkspell
  python-libxml2 python-mako python-markupsafe python-notify python-openssl
  python-parted python-uno python-wnck python-xapian rsyslog ruby1.8 samba
  samba-common samba-common-bin sane-utils simple-scan system-tools-backends
  sysvinit telepathy-gabble telepathy-mission-control-5 thunderbird
  thunderbird-l10n-en-us transmission-common transmission-gtk ttf-dejavu
  ttf-dejavu-core ttf-dejavu-extra ttf-opensymbol ufraw-batch ufw uno-libs3
  update-inetd ure usb-modeswitch usb-modeswitch-data usbutils uuid-runtime
  vim-common vim-tiny vino vlc-data w3m wget wvdial xdg-user-dirs xinit xnest
  xserver-xorg xserver-xorg-input-all xserver-xorg-video-all xsltproc xz-utils
  zenity
Preconfiguring packages ...
309 upgraded, 49 newly installed, 8 to remove and 4 not upgraded.
Need to get 0 B/424 MB of archives.
After this operation, 325 MB of additional disk space will be used.
(Reading database ... 
(Reading database ... 137421 files and directories currently installed.)
Preparing to replace gstreamer0.10-plugins-bad 0.10.22-2 (using .../gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb) ...
Unpacking replacement gstreamer0.10-plugins-bad ...
dpkg: error processing /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb

Evidently, gstreamer-plugins-bad had an ugly (pun!) time trying to uninstall itself or be replaced. Weird. I've never seen this problem in "all my years" of Ubuntu administration, which is probably because people are working around the clock to make sure that I don't see issues like this.

How can I fix this issue?

share|improve this question
2  
Tried aptitude's text user interface? (Just run sudo aptitude in a terminal.) It should recognize something's weird and probably offer some alternatives. (I hope LMDE ships it.) –  sr_ Mar 6 '12 at 17:42
    
I haven't tried it yet. I've always liked aptitude better than apt. I'll give it a go. –  Naftuli Tzvi Kay Mar 6 '12 at 17:44
    
aptitude basically fixed everything :) –  Naftuli Tzvi Kay Mar 6 '12 at 19:54

3 Answers 3

up vote 2 down vote accepted

The gstreamer0.10-plugins-bad package version 0.10.22-3 replaces file which are also in gstreamer0.10-plugins-really-bad version 0.10.22-0.1. It seems to be a bug that it does not work here without any errors (see here for more information). But if you mix versions from different distributions, a clear upgrade path is not guaranteed.

To solve the problem, just remove the gstreamer0.10-plugins-really-bad package, by using aptitude purge gstreamer0.10-plugins-really-bad or apt-get remove --purge gstreamer0.10-plugins-really-bad.

share|improve this answer

This is really weird, it seems that you have three versions of gstreamer0.10-plugins-bad :

  1. Installed Version not up-to-date : 0.10.22-2
  2. Available version up-to-date : 0.10.22-3
  3. A wtf version : 0.10.22-0.1

I guess that you need to remove this "0.10.22-0.1" version, in a way or another. You can either try :

apt-get install gstreamer0.10-plugins-really-bad=0.10.22-0.1

or

dpkg -r gstreamer0.10-plugins-really-bad

In order to remove version 0.10.22-2 or 0.10.22-0.1. After that you have only 1 version of this package on your system, you should be able to upgrade.

NB: It would be probably better if you also remove and reinstall this one, in order to get back an healthy system.

share|improve this answer

It is also possible to force installation of a package even though it overwrites files from a different package. Of course it is usually not recommended, etc., but the tools give you the power to do it.

sudo dpkg --force-overwrite -i /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.