Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After acquiring a new virtual Debian squeeze I ran into a problem regarding loop devices. My plan was to set up an encrypted FS in a regular file and mount it. Unfortunately I can't do that since there are no loop devices in /dev. mount tells me to run modprobe loop, but modprobe fails with

FATAL: Could not load /lib/modules/2.6.32-5-vserver-amd64/modules.dep: No such file or directory

/lib/modules is empty. Still, the loop module seems to be loaded according to lsmod, so I created an /etc/modprobe.conf containing

options loop max_loop=8

and restarted the server. Still nothing.

I tried to google every part of the problem, but no site seems to have something on this particular problem. Any ideas?

share|improve this question
It seems rather non-trivial, judging from this (i.e. it needs patching) -- no idea how recent/still-needed this howto is, though – sr_ Mar 6 '12 at 16:11
your VPS host probably doesn't want you to use loop devices? – sendmoreinfo Jun 9 '13 at 15:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.