Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just tried booting the Ubuntu 10.10 64 bit live USB on this machine and to my amazement everything works fine. I even installed the system, after which I checked with uname -a and the result is

Linux T205-04 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:32:27 UTC 2010 x86_64 GNU/Linux

This is quite confusing to me. To my knowledge Pentium 4 is 32 bit only. How was that possible?

Below is the result of cat /proc/cpuinfo (there are 2 CPUs, but the information is the same)

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping        : 3
cpu MHz         : 2800.000
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 1
apicid          : 1
initial apicid  : 1
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
 pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm
 constant_tsc pebs bts pni dtes64 monitor ds_cpl est cid cx16 xtpr
bogomips        : 6000.41
clflush size    : 64
cache_alignment : 128
address sizes   : 36 bits physical, 48 bits virtual
power management:
share|improve this question
up vote 13 down vote accepted

From Wikipedia: “In 2004, the initial 32-bit x86 instruction set of the Pentium 4 microprocessors was extended by the 64-bit x86-64 set.”

Your /proc/cpuinfo output shows flags: … lm …. The flag lm stands for “long mode“ which means 64-Bit extension. Thus, you have indeed a 64-bit processor.

share|improve this answer
48 bits virtual also shows that it has 48-bit addressing. (there are no 64-bit address bus x86 yet, but they all do 64-bit data). The 36 bits physical could also be shown if it has pae but not 64-bit. – richard 6 hours ago

Apparently there were some 64 bit pentium 4 chips made. Check your processor with cat /proc/cpuinfo

share|improve this answer
I checked, but don't see any clue whether it is 32 or 64, which part of /proc/cpuinfo says so? – phunehehe Oct 21 '10 at 3:04
Post the whole thing – Falmarri Oct 21 '10 at 3:05
the information is the same, really. the only exception was the processor : 1 line – phunehehe Oct 21 '10 at 10:35
From the /proc/cpuinfo you posted, it seems that Falmarri was right and that you were able to install it because you have a 64-bit P4. Note the "lm" flag in the output. – Steven D Oct 21 '10 at 14:35

If you got P4 630 775 socket, like me, you can easly run 64-bit OSes.

share|improve this answer

I expect you have a DUAL CORE Pentium 4 and this enables you to run 64bit code. The earlier single processor P4s ran at a lower speed and only worked 32bit.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.