Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have been stuck for a few hours trying to install lcov on a debian 6 box. Any help would be greatly appreciated!

What I have tried the following in the command line:

root@damrod-ci:/etc/munin/plugins# apt-get install lcov
Reading package lists... Done Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these: The following packages have unmet dependencies:   libpango1.0-0: Breaks:
plymouth (< 0.8.3-19) but 0.8.2-2ubuntu2.2 is to be installed E:
Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@damrod-ci:/etc/munin/plugins# apt-get -f install
Reading package lists... Done Building dependency tree        Reading
state information... Done Correcting dependencies... Done The
following packages were automatically installed and are no longer
required:   libgnumail-java libts-0.0-0 libcdio10 junit4
libgsf-1-common libarchive1 libntfs10 libgeronimo-jms-1.1-spec-java
libcdio-paranoia0 libcupsimage2   libgphoto2-port0 libmagickcore2
libservlet2.4-java antlr gvfs-backends obex-data-server
libimobiledevice0 libmockobjects-java libgnuinet-java   libasm2-java
libproxy0 libplexus-component-api-java libmagickwand2
libsoup-gnome2.4-1 libdirectfb-1.2-0 libxstream-java
libpango1.0-common   libgnujaf-java radiusclient1 libgsf-1-114 ivy
libopenobex1 lm-sensors libradius1 fancontrol libxpp3-java libgs8
psfontmgr tsconf ghostscript   libcdio-cdda0 libhamcrest-java groovy
libexif12 libpaper-utils libxcb-render-util0 libbluetooth3 libpaper1
libjs-mootools libgphoto2-2 Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:   plymouth The
following packages will be upgraded:   plymouth 1 upgraded, 0 newly
installed, 0 to remove and 278 not upgraded. 179 not fully installed
or removed. Need to get 0B/141kB of archives. After this operation,
69.6kB of additional disk space will be used. Do you want to continue [Y/n]? y WARNING: The following packages cannot be authenticated!  
plymouth Install these packages without verification [y/N]? y (Reading
database ... 85730 files and directories currently installed.)
Preparing to replace plymouth 0.8.2-2ubuntu2.2 (using
.../plymouth_0.8.3-20_amd64.deb) ... Unpacking replacement plymouth
... dpkg: error processing
/var/cache/apt/archives/plymouth_0.8.3-20_amd64.deb (--unpack): 
trying to overwrite '/lib/libply-splash-core.so.2.0.0', which is also
in package libplymouth2 0.8.2-2ubuntu2.2 Processing triggers for
initramfs-tools ... update-initramfs: Generating
/boot/initrd.img-2.6.32-33-server Processing triggers for ureadahead
**... Errors were encountered while processing: 
/var/cache/apt/archives/plymouth_0.8.3-20_amd64.deb E: Sub-process
/usr/bin/dpkg returned an error code (1)

My sources.list

#############################################################
################### OFFICIAL DEBIAN REPOS ###################
#############################################################

###### Debian Main Repos deb http://ftp.nz.debian.org/debian/ squeeze main contrib non-free  deb-src http://ftp.nz.debian.org/debian/
squeeze main contrib non-free 

###### Debian Update Repos deb http://ftp.nz.debian.org/debian/ squeeze-proposed-updates main contrib non-free 

##############################################################
##################### UNOFFICIAL  REPOS ######################
##############################################################

###### 3rd Party Binary Repos

#### Dotdeb - http://www.dotdeb.org deb http://packages.dotdeb.org oldstable all


####### 3rd Party Source Repos

#### Dotdeb (Source) - http://www.dotdeb.org deb-src http://packages.dotdeb.org oldstable all
share|improve this question

2 Answers 2

up vote 1 down vote accepted

Your problem is that you've tried to mix Ubuntu packages on your Debian system.

Ubuntu is different for a reason. If you want to run Ubuntu then run Ubuntu. If you don't then don't try to install Ubuntu packages on Debian.

To be clear: there is nothing wrong with the lcov package. If you examine the error message it says that libpango (presumably a dependancy of lcov) can't be installed because it will break plymouth, which it clearly states is an Ubuntu package.

share|improve this answer
    
Thanks man! lcov is a debian package but someone seems to have installed a ubuntu version of plymouth, I downgraded plymouth to the squeeze version and it is now all good! –  P4ul Mar 4 '12 at 22:16

As already noted by bahamat, you have installed plymouth packages from Ubuntu on your system which breaks existing packages.

To solve your problem: Remove all plymouth packages and then install the current stable package version from Debian:

apt-get remove plymouth libplymouth2
apt-get install plymouth

To avoid situation like that in the future, never use dpkg -i directly. In the rare case you really need to install packages from Ubuntu (or from another repository), create a corresponding entry in /etc/apt/sources.list and use aptitude/apt-get to install the package. It helps avoiding any conflicts between the packages. If you cannot install a package at all because of missing dependencies, rebuilding the package could help.

But please note, that installing packages coming from other places than the official, could introduce problems of all kinds, including security issues.

share|improve this answer
    
Thanks for your answer, I figured out a similar solution from @bahamat's post. I used aptitude to remove plymouth and it downgraded it to the squeeze version. –  P4ul Mar 4 '12 at 22:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.