Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I got an error message when launching "xdg-open" , No applications found for mimetype: inode/mount-point

How should I add a binding for "dolphin" ?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

I glanced over the xdg-open source and saw that it uses xdg-mime to figure out the type. man xdg-mime revealed a default option to set the application to be used:

xdg-mime default application mimetype(s)
...
default
   Ask the desktop environment to make application the default
   application for opening files of type mimetype. An application can
   be made the default for several file types by specifying multiple
   mimetypes.

   application is the desktop file id of the application and has the
   form vendor-name.desktop application must already be installed in
   the desktop menu before it can be made the default handler. The
   aplication's desktop file must list support for all the MIME types
   that it wishes to be the default handler for.

For more about this, see the relevant man pages.

share|improve this answer
add comment

I am not 100% sure, but I think xdg-open relies on what you set in 'file types' in your DE's configuration. I guess you are on KDE, so open KDE system settings and specify that file type.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.