Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running Fedora 16. When I'm using vim or the terminal and I mistakenly direct the cursor to an inaccessible place, eg when the cursor is all the way to the top or left of the screen, the whole screen blinks. How can I disable this?

I really like fedora but this setting drives me nuts.

share|improve this question
    
Most terminals let you choose between that screen flash and an audible bell. Some let you turn it off, so that you wouldn't depend on a per-application setting. What terminal emulator do you use? –  Gilles Mar 2 '12 at 22:32
add comment

1 Answer 1

up vote 3 down vote accepted

It's called "Visual Bell" - see this question for how to fix it in bash.

set bell-style none
share|improve this answer
    
Thanks for pointing that put, I didn't know that it was called visual bell. I've entered 'set bell-style none' and bind 'set bell-style none' in the .bashrc file but it hasn't had any effect. I've been able to turn it off in vim though, see below. unix.stackexchange.com/questions/5310/… –  NiallJG Mar 2 '12 at 2:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.