Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have been trying to mount a drive, but anything i do i get 'Access Denied',

I tried:

mount -t cifs //192.168.x.x/m -o username=user,password=mypass /mnt/mymount

mount -t cifs //192.168.x.x/m -o credentials=cred /mnt/mymount

mount -t cifs //192.168.x.x/m -o username=user,password=mypass,domain=xxxxx /mnt/mymount

I want to user a local user account on the windows machine and not a domain user account. Is this possible? I tried to put in the computer name as the domain, the fully qualified domain name, also under username i tried computer\user, none of those seem to work.

Any other ideas?

Thanks.

share|improve this question
1  
Have you checked Event Log on the Windows machine? –  Karlson Mar 2 '12 at 3:10
add comment

1 Answer

You need to create a Samba user corresponding to the Linux user whose share you are trying to mount. Try running smbpasswd -a user to create a Samba password entry for user user.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.