Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm playing with iscsi and I'm trying to figure out why the vendor/product names aren't showing up correctly. I've restarted all the appropriate services along with a reboot.

Listed below are the output along with an excerpt of the config file.

Output:

LUN-48 (1IET_00020001) dm-0 IET,VIRTUAL-DISK
size=480M features='0' hwhandler='0' wp=rw
|-+- policy='round-robin 0' prio=0 status=enabled
| `- 3:0:0:1 sdb 8:16 failed faulty running
`-+- policy='round-robin 0' prio=1 status=active
`- 7:0:0:1 sdd 8:48 active ready  running
LUN-30 (1IET_00010001) dm-1 IET,VIRTUAL-DISK
size=300M features='0' hwhandler='0' wp=rw
|-+- policy='round-robin 0' prio=1 status=active
| `- 8:0:0:1 sdc 8:32 active ready  running
`-+- policy='round-robin 0' prio=0 status=enabled
`- 5:0:0:1 sde 8:64 failed faulty running

Here's an excerpt from multipath.conf

devices {
    device {
            vendor "VMware"
            product "Virtual Disk"
    }
}
share|improve this question
    
What do you want to see where and why? –  Nils May 1 '12 at 20:01
add comment

1 Answer

I'm not sure what you expect your multipath.conf file to accomplish, but what you've shown above is effectively a no-op as far as I can tell. The device section matches devices based on the vendor, product, and revision keywords, and then applies specific overrides. You have some match criteria there, but you're not actually providing configuration information.

Take a look at this document, which shows an example devices section that overrides some global configuration options.

Other than that, the vendor and product names look just fine. IET is the vendor reported by the iSCSI Enterprise Target driver, so I assume that's where you're getting your LUNs.

share|improve this answer
    
Yea, I was talking to a coworker who told me you could apply whatever name you want to the "Device," but apparently that isn't the case. I spent an hour or so trying to get the name to display correctly. –  luckytaxi Mar 2 '12 at 18:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.