Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I set up byobu auto run with the command byobu-enable. It's great when I log in from terminal or ssh, but how can I make xterm attach to it automatically ? (mate-terminal from Linux mint especially)

share|improve this question

migrated from stackoverflow.com Mar 1 '12 at 13:34

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Byobu actually installs a desktop application, too. In classic Gnome (Mint?), this should be under Applications -> Accessories.

When you run byobu-enable, it places a line at the end of your ~/.profile. If you want byobu to launch every time you run xterm, then you should add that line to ~/.bashrc instead. Note that if you're using tmux (rather than screen) as your byobu backend, you'll need to unset the $TMUX variable too. Try this:

echo "_byobu_sourced=1 TMUX= . /usr/bin/byobu-launch" >> ~/.bashrc

Full disclosure: I am the original author and current maintainer of Byobu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.