Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In a network, due to a reason that I don't know, I can't browse the web in Linux(In windows it has no problem). I get Error 301 moved permanently when I try to load a web page.

I decided to bypass this restriction by using SSH tunnel. I can connect to ssh server with the following command:

ssh user@server -D 1024

Problem is: even using ssh tunnel I still can't browse the web. Using firefox, in status bar I see "Waiting for example.com" But it doesn't load the website and remains in this status.

I have tested the above command in another networks to create tunnel with no problem.

share|improve this question
    
are you sure there are no strange proxy settings set? – SkaveRat Feb 29 '12 at 19:09
    
Yes. I'm completely sure! – hknik Feb 29 '12 at 19:12
    
Are you connected directly or throght proxy? can you telnet www.domain.com 80 or wget somedomain/url ? – rkosegi Feb 29 '12 at 20:26
    
Are you configuring the browser for a http proxy or a socks proxy? ssh -D is a socks proxy. – Patrick Feb 29 '12 at 21:38
    
All configurations are the same as when it works in another network. One thing that differs is, in this network I connect through a VPN connection. – hknik Mar 1 '12 at 7:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.