Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm upgrading my server but an error occurred. Here is the error report:

Transaction Check Error:
  package subversion-1.6.15-0.1.el5.rfx.x86_64 (which is newer than subversion-1.6.11-7.el5_6.4.i386) is already installed
  file /usr/share/emacs/site-lisp/psvn.el from install of subversion-1.6.11-7.el5_6.4.i386 conflicts with file from package subversion-1.6.15-0.1.el5.rfx.x86_64
  file /usr/share/locale/zh_CN/LC_MESSAGES/subversion.mo from install of subversion-1.6.11-7.el5_6.4.i386 conflicts with file from package subversion-1.6.15-0.1.el5.rfx.x86_64
  file /usr/share/xemacs/site-packages/lisp/psvn.el from install of subversion-1.6.11-7.el5_6.4.i386 conflicts with file from package subversion-1.6.15-0.1.el5.rfx.x86_64
share|improve this question
2  
...and your question is? It looks like someone installed a newer version of subversion already; it's probably harmless (if this server is not used for hosting something subversion-related in which case you possibly need to be a bit more careful). –  sr_ Feb 29 '12 at 12:39
    
Did none of the answers solve your problem? –  vonbrand Mar 14 '13 at 0:25

2 Answers 2

You already have a version installed.

You can try to clean using

rpm -e --nodeps --allmatches <packagename>

This will erase all packages that match the packagename and not check the dependencies before it does. After that you should be able to yum update successfully.

share|improve this answer
    
tks. problem solved :D –  TomSawyer Mar 1 '12 at 19:08
1  
Never use --nodeps, you are creating an inconsistency! –  vonbrand Jan 26 '13 at 2:02
    
Absolutely agree with @vonbrand. -1 from me. –  Deer Hunter Jan 26 '13 at 5:27

This means that a newer version of the package than the one in the upgrade is already installed. This should work right if you tell the upgrade to use the updates for the upgraded version.

In any case, CentOS really doesn't need to be upgraded explicitly during a series. That is, if you originally installed CentOS 5.0 and updated rigurously, by the time CentOS 5.2 comes out you already have that installed through package updates. CentOS 5.2 just rolls all the updates into one installable set. You'd need to upgrade when CentOS 6.0 comes out, or upgrade directly to, say, CentOS 6.2.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.