Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Git 1.7.9.1 on Arch Linux:

git svn init -s https://app.svn.beanstalk.com/repo
Initialized empty Git repository in /path/to/repo/.git/
Authentication realm: <https://app.svn.beanstalk.com/repo:443> SVN    
Password for 'localuser':
Authentication realm: <https://app.svn.beanstalk.com/repo:443> SVN
Username: remoteuser
Password for 'remoteuser':
Authentication realm: <https://app.svn.beanstalk.com/repo:443> SVN
Username:

No matter how many times I enter my details, it never accepts them. I have logged in successfully with the same credentials in a web browser. I have also tried this without the -s, and with the --no-minimize-url flags. What's going on?

share|improve this question
    
Do you know if it's Basic, Digest, NTLM, or Negotiate authnetication? –  penguin359 Mar 2 '12 at 22:50
    
Pretty sure it's Basic. –  Hugh Guiney Mar 3 '12 at 3:29
    
Did you try svn directly? Did you try accessing the server directly per http? This probably isn't related to git or even svn. –  JonnyJD Dec 25 '12 at 16:21
    
I have the same scenario using git-svn on windows in the mingw32 shell with Git 1.8.5.5. On my Windows x64 machine I am running TortoiseSVN 1.7.5 with SVN 1.7.3 and I can connect with SVN-cached credentials through both Tortoise and SVN command line yet when I attempt to clone the same SVN url with git-svn I get the behavior described above. –  David Alpert Feb 14 at 22:46
    
Apparently this problem went away for me after I entered my domain credentials (username, then password) 3 or 4 times in a row. Now my git-svn is working against the local svn repos just fine. –  David Alpert Feb 15 at 18:25
add comment

1 Answer 1

I've found that it's a bug in the latest version 1.9.0, in the previous one 1.8.5.2 I can successfully authenticate.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.