Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have installed both Windows and SUSE Linux (11.4) on my Dell Inspiron 14r laptop. Both are working properly.

I am facing one strange problem.

I went to my Linux OS wifi was working fine and I pressed fn+f2 in-order to disable wifi.
Wifi got disable successfully but when I again pressed fn+f2 it is not enabling wifi. I can see wifi disabled. Instead of that bluetooth icon got enable.

Then I switched to Windows and again pressed fn+f2 and wifi got enabled. Then I switched to linux OS and I can see my wifi enabled. Again I pressed fn+f2 and it got disabled and I'm not able to enable it by pressing fn+f2 again.

How can I enable wifi on SUSE (11.4)?

share|improve this question
    
As a preliminary step, check your journal output and/or logs to see what happens when you press Fn + F2; I'm assuming your wifi connection isn't handled by NetworkManager or something similar, which would bind the interface automatically to your wifi-AP when it's brought back up. –  ILMostro_7 Jun 22 at 10:36

3 Answers 3

Use yast2 for it yast2 lan or yast lan managing network devices with yast is much easier and better.

share|improve this answer

The same thing just happened to me... check this:

~# iwlist wlan0 scan
wlan0     Interface doesn't support scanning : Network is down

ok then do this:

~# dhclient wlan0
RTNETLINK answers: Operation not possible due to RF-kill

cancel it if it take too long.

and do it again:

~# iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: 94:0C:6D:A7:96:3C
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=33/70  Signal level=-77 dBm  
                    Encryption key:on
                    ESSID:"TP-LINK_A7963C"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              12 Mb/s; 24 Mb/s; 36 Mb/s
                    Bit Rates:9 Mb/s; 18 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000007e1de6a181
                    Extra: Last beacon: 548ms ago
                    IE: Unknown: 000E54502D4C494E4B5F413739363343
                    IE: Unknown: 010882848B960C183048
                    IE: Unknown: 030106
                    IE: Unknown: 2A0100
                    IE: Unknown: 32041224606C
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                       Preauthentication Supported
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
          Cell 02 - Address: 00:26:44:85:C2:47
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=48/70  Signal level=-62 dBm  
                    Encryption key:on
                    ESSID:"ThomsonEDDA75"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000003a107ef188
                    Extra: Last beacon: 540ms ago
                    IE: Unknown: 000D54686F6D736F6E454444413735
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030106
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32040C121860
                    IE: Unknown: DD7F0050F204104A0001101044000102103B0001031047001017EE179186BD5CEA925EA803929929E11021000754484F4D534F4E1023000A54686F6D736F6E20544710240006353835207637104200093130323954465335351054000800060050F204000110110008544735383720563710080002000410570001001041000100
                    IE: Unknown: DD060010180200F0
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK

now it's works!

re-do this:

dhclient wlan0
share|improve this answer
    
check your rfkill list of blocked devices: $ rfkill list –  ILMostro_7 Jun 22 at 10:29
ifconfig wlan0 up 

Replace wlan0 with your wireless device. To see yours, you can type in ifconfig -a

share|improve this answer
1  
i tried this but still not working. ifconfig -a result shows eth0,lo and wlan0 i executed ifconfig waln0 up but no effect. any idea? –  Suri Apr 14 '12 at 16:53
    
in network manager icon on system tray enable wireless i unchecked and disabled. –  Suri Apr 15 '12 at 5:42
    
if the wlan0 interface is showing up already upon execution of ifconfig, then the above command won't have an effect on it--since it's already up! –  ILMostro_7 Jun 22 at 10:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.