Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

There's a package libvpx-0.9.7 which is required by empathy application. Now I want to install another application which requires libvpx-1.0... Update is not allowed because some applications depend on the old version. What's the solution to this situation?

share|improve this question
1  
Have you installed packages from somewhere other than the official Fedora repositories? What is this "other application" you're trying to install? Where does it come form? –  larsks Feb 25 '12 at 0:07
    
I'm trying to install skype, it requires libQtGui.so.4 which is not installed because of the versions conflict –  Sergey Feb 25 '12 at 9:02
    
What is the package that requires libvpx-0.9.7? –  Shauna Mar 26 '12 at 16:38
add comment

1 Answer

up vote 2 down vote accepted

I'm running Fedora 16 and Skype. And I have Empathy installed. Empathy does not have any requirement (either explicit or implicit) on libvpx:

# rpm -q --requires empathy | grep -i vpx

And in fact, very few things depend on it directly:

# rpm -e libvpx
error: Failed dependencies:
    libvpx.so.1()(64bit) is needed by (installed) xulrunner-10.0-1.fc16.x86_64
    libvpx.so.1()(64bit) is needed by (installed) gstreamer-plugins-bad-free-0.10.22-2.fc16.2.x86_64

I have this Skype package installed:

# rpm -q skype
skype-2.2.0.35-fc10.i586

And this version of libvpx:

# rpm -q libvpx
libvpx-1.0.0-1.fc16.x86_64

In fact, libvpx 0.9.7 does not appear to be available in the Fedora 16 repositories.

I would make sure that all your existing packages have actually come from the Fedora 16 repositories.

share|improve this answer
    
skype requires libQtGui.so.4, libQtGui.so.4 is not installed because of many "Protected multilib versions:..." -version conflicts. –  Sergey Feb 25 '12 at 14:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.