Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I upgraded to PHP5.3 using this tutorial: http://www.debiantutorials.com/how-to-install-upgrade-to-php-5-3-on-debian-lenny/

It removed the following packages:

Removing php-pear ...
Removing php5-pgsql ...
Removing php5-mysql ...
Removing php5-mcrypt ...
Removing php5-ldap ...
Removing php5-gd ...
Removing php5-curl ...
Removing php5-sasl ...
Removing php5-cli ...

All seemed well, it warned me those packages would be removed, which was fine, I figured I could just install them after. But now, when I try, it warns me that I am missing dependencies:

The following packages have unmet dependencies:
  php5-cli: Depends: libc6 (>= 2.11) but 2.7-18lenny7 is to be installed
            Depends: libdb4.8 but it is not installable
            Depends: libgssapi-krb5-2 (>= 1.6.dfsg.2) but it is not installable
            Depends: libk5crypto3 (>= 1.6.dfsg.2) but it is not installable
            Depends: libkrb5-3 (>= 1.6.dfsg.2) but it is not installable
            Depends: libncurses5 (>= 5.7+20100313) but 5.7+20081213-1 is to be installed
            Depends: libreadline6 (>= 6.0) but it is not installable
            Depends: libssl0.9.8 (>= 0.9.8m-1) but 0.9.8g-15+lenny16 is to be installed
            Depends: libxml2 (>= 2.7.4) but 2.6.32.dfsg-5+lenny5 is to be installed
E: Broken packages

What can I do to fix this issue and get these back?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.