Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When running an interactive shell application, how can I send it a key (or key combination) which would normally be intercepted by GNOME Terminal? In this particular instance it's the F10 key which is intercepted.

Bonus points for a general-purpose solution which would work for things like Alt, PgUp and Alt-Tab (might be useful for a shell script to configure shortcut commands) or in other terminals as well.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

You can try disable the gnome shortcuts in Edit -> Keyboard shortcuts, so the window won't eat up the function keys.

There seems to be a known gnome-terminal bug relating to this.

Alternatively if this doesn't work, you will have to use another terminal that explicitly sends function keys as control codes to the terminal. rxvt is one I can recommend, or xterm.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.