Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have been made to install CentOS-5.5 on my desktop. The network is not working. These following are the outputs of various commands.

#ifconfig
lo link encap:local loopback
inet addr 127.0.0.1 mask 255.0.0.0
.....(goes on)

There is no other device other than 'lo' in the ifconfig output.

#chkconfig --list|grep -i network
networkmanager 0:off .... (every thing off)
network (2,3,4,5 on ; and rest of them off)

#service NetworkManager status
networkmanager is stopped

#service network status
configured devices:
lo
currently active devices:
lo

there is nothing in the /etc/resolv.conf file

regards

share|improve this question
    
What is the model of the network card? –  Renan Feb 23 '12 at 2:10
    
@RenanBirckPinheiro output of lspci |grep net is 00:19.0 Ethernet controller: intel corporation unknown device 1502 (rev 04) . I hope that adds some extra information –  salsabear Feb 23 '12 at 2:22
1  
@RenanBirckPinheiro with a bit more searching it seems like this is the CPU i am using is link. And the following is given in the connectivity section Integrated Intel® 82579LM Ethernet LAN 10/100/1000 Optional Broadcom® NetXtreme® 10/100/1000 PCIe card Optional Dell Wireless 1520 PCIe (MT, DT, SFF) Optional half-mini PCIe (USFF) WLAN card (802.11n) –  salsabear Feb 23 '12 at 2:28
    
can you try installing a newer version of CentOS (5.8 or 6.2)? It might be supported (instead of being recognized as an "unknown device") with an updated kernel. –  Renan Feb 23 '12 at 2:31
    
@RenanBirckPinheiro centos-5.5 is the most preferred OS for us. I need to check if there are alternatives to make the network work before giving up! –  salsabear Feb 23 '12 at 2:46

3 Answers 3

As you said, your network card is

00:19.0 Ethernet controller: intel corporation unknown device 1502 (rev 04)

This makes me think that, being seen as an 'unknown device', it's not supported by CentOS 5.5. Can you try a more recent CentOS version (CentOS 5.7 or CentOS 6.2)?

According to this, CentOS 5.7 should recognize the card.

Try installing kernel-2.6.18-274.18.1.el5.x86_64.rpm and kmod-igb-rhel5u7-3.0.6_k2_1.1-1.el5_7.x86_64.rpm from a mirror, such as this one.

(replace x86_64 with i386 if you're using 32-bit CentOS).

The kmod-igb package is for supporting the network card you have in that machine.

share|improve this answer
    
CentOS-5.5 is the most preferred OS for us. I am not sure but, does installing driver for that particular network card solve the problem? I am ready to take a beating before giving up! –  salsabear Feb 23 '12 at 2:40
    
You can try to install the CentOS 5.8 kernel (get the RPMs from a mirror). –  Renan Feb 23 '12 at 2:55
    
CentOS-5.7 is last one in the CentOS-5 series. I shall install it's kernel and see if that solves the problem. –  salsabear Feb 23 '12 at 4:21
    
Indeed, my fault, I thought the latest CentOS was 5.8. –  Renan Feb 23 '12 at 4:23
    
I have installed the rpm file I found in this directory. (if you search "kernel" in that page, you could easily find it.) The new kernels that show up at boot time are 2.6.18-194.el15 and 2.6.18-194.el15PAE. (neither of them work) But actually kernel I have installed is of version 2.6.18-294. Also, that rpm file was an SRPM, it if matters.. –  salsabear Feb 23 '12 at 5:16

Intel has very good drivers that blend into your OS. Download them, compile them and install them.

share|improve this answer

ifconfig -a will give you the status of all interfaces. If you do not specify any arguments or options, ifconfig will only display active interfaces.

If you have a desktop GUI environment you may be able to follow this guide to get networking up. If you do not have a GUI desktop environment installed, then system-config-network-tui as root may be of use. If you do not have the package providing the tui executable, you may have to install from the Internet or CDROM. I realize the paradoxical nature of what I just said, and you may be able to temporarily enable the NIC by running ifup eth0 and dhclient eth0, if you expect a DHCP address. Even if this succeeds, this should not persist between reboots unless you make further configuration changes and save them.

Specifically, if you edit /etc/sysconfig/network-scripts/ifcfg-eth0 you should be able to set the device to be brought up on boot (ONBOOT=yes) and use DHCP (BOOTPROTO=dhcp). Again this depends on whether or not you expect DHCP.

share|improve this answer
    
there are no entries in any of the tabs in the system-config-network window.. –  salsabear Feb 23 '12 at 2:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.