Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running F16 on VMplayer, I don't think the drivers I'm using are for my nvidia card. I'm getting a max resolution of 1280*768.

My card is EVGA 9800GTX+ --- I need instructions on how to change my xorg config (I'm assuming that's the problem).


In gnome display settings I'm now able to set my resolution to 1920x1080

After forcing vmware driver in xorg.conf My xorg.conf looks like this atm;

Section "Device"
    Identifier "device0"
    VendorName "VMware SVGA II Adapter"
    BoardName "VMware SVGA II Adapter"
    Driver "vmware"
    Option "SWcursor"
EndSection

Section "Screen"
    Identifier "screen0"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
Subsection "Display"
    Depth 8
    Modes "1920x1080"
EndSubsection
Subsection "Display"
    Depth 15
    Modes "1920x1080"
EndSubsection
Subsection "Display"
    Depth 16
    Modes "1920x1080"
EndSubsection
Subsection "Display"
    Depth 24
    Modes "1920x1080"
EndSubsection
EndSection

After logging in my resolution changes to 1920x1080 The only setting being picked up by xorg.conf is driver vmware At login screen my resolution is 1024x768

share|improve this question
1  
You have installed the VMware Tools? They are needed if you want to get higher resolutions. –  Renan Feb 20 '12 at 1:09
    
@RenanBirckPinheiro, yes I ran ran vmware-tools without problems, but I'll run the script again. –  RzK Feb 20 '12 at 1:12
    
It is as Renan says. I too am using Fedora (version 15) or VMWare Fusion. The resolution immediately maxed out to full screen after a successful installation of VMWare tools. Do a google search on what you need to do to properly install it. –  sj755 Feb 20 '12 at 1:15
    
@seljuq70 Ok, I'm trying it again at the moment, hope your both right, thanks. –  RzK Feb 20 '12 at 1:22
    
Reinstalled vmware-tools and rebooted to no avail. –  RzK Feb 20 '12 at 1:49

2 Answers 2

Faced with the same problem after installing VMware. My system is:

root@:~#uname -a
FreeBSD 9.2-RELEASE FreeBSD 9.2-RELEASE # 0 r255898: Thu Sep 26 22:50:31 UTC 2013 root@bake.isc.freebsd.org:/usr/obj/usr/src/sys/GENERIC amd64

OK.Solution: go to the "/etc/X11/xorg.conf"

Section "Device"
    Identifier "VMware SVGA"
    Driver "vmware"
EndSection

change it to

Section "Device"
    Identifier "VMware SVGA"
    Driver "vesa"
EndSection

Next, look for

Section "Screen"
    Identifier "Screen 1"
    Device "VMware SVGA"
    Monitor "vmware"
    # Don't specify DefaultColorDepth unless you know what you're
    ...
EndSection

add "DefaultColorDepth 24"

Section "Screen"
    Identifier "Screen 1"
    Device "VMware SVGA"
    Monitor "vmware"
    DefaultColorDepth 24
    # Don't specify DefaultColorDepth unless you know what you're
    ...
EndSection

Next, look for section "display" where "Depht 24" and change the value to the desired resolution Example:

Subsection "Display"
    Depth 24
    Modes "1920x1080"
    ViewPort 0 0
EndSubsection

save "/etc/X11/xorg.conf" leave.Next

root@:~#startx

leave.Next

root@:~#cat /var/log/Xorg.0.log|grep 1920x1080

will show something like this

(II) vmwlegacy (0): Modeline "vmware-default-1920x1080" x1.0 2.60 1920 1921 1922 2402 1080 1081 1082 1083 (1.1 kHz)

Write down where or whether these values:

"1920x1080" 2.60 1920 1921 1922 2402 1080 1081 1082 1083

Later, they will come in handy. OK

Then again, edit the "/etc/X11/xorg.conf"

Section "Device"
    Identifier "VMware SVGA"
    Driver "vesa"
EndSection

change it to

Section "Device"
    Identifier "VMware SVGA"
    Driver "vmware"
EndSection

Next, look for

Section "Monitor"
    Identifier "vmware"
    VendorName "VMware, Inc"
    HorizSync 1-10000
    VertRefresh 1-10000
EndSection

add item "ModeLine" and insert there our recorded value (the output of Xorg.0.log)

Section "Monitor"
    Identifier "vmware"
    VendorName "VMware, Inc"
    ModeLine "1920x1080" 2.60 1920 1921 1922 2402 1080 1081 1082 1083
    HorizSync 1-10000
    VertRefresh 1-10000
EndSection

save "/etc/X11/xorg.conf"

root@:~#startx

rejoice! =)

share|improve this answer
up vote 1 down vote accepted

Partially Solved, although vmware tools did not install properly, the xorg drivers for vmware were installed but xorg.conf wasn't pointing to those drivers.

I changed the driver from default vesa to vmware.. full list of resolutions is now available under gnome settings.

My xorg.conf at the moment;

Section "Device"
    Identifier "Display0"
    Driver     "vmware"
EndSection

Make sure you have the driver installed;

yum install xorg-x11-drv-vmware

Hope that helps someone who comes across the same problem. GDM still boots with 640x486, but after login gnome settings take priority and display my resolution of 1920x1080. I gave up on trying to completely fix my problem, and removed F16 and installed Ubuntu Server 11.10. I also tried Ubuntu 11.10 desktop x86, which was trouble free when it came down to installing vmware-tools.

Hopefully this will help those having problems with vmware-tools.

Also helpful links thanks to seljuq70

http://www.sysprobs.com/fedora-14-vmware-install-vmware-tools-fedora-14

http://www.crazyhawt.com/2010/01/25/quick-guide-installing-vmware-tools-with-fedora-12/


I haven't tried this but the problem with the GDM resolution probably has to do with a setting in grub.conf, I read about it after I had already removed F16 from vmplayer.

But for those who have problems with pre-login resolution, may want to look at this. http://pierre.baudu.in/other/grub.vga.modes.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.